zoukankan      html  css  js  c++  java
  • 快速切题 sgu120. Archipelago 计算几何

    120. Archipelago

    time limit per test: 0.25 sec. 
    memory limit per test: 4096 KB

     

    Archipelago Ber-Islands consists of N islands that are vertices of equiangular and equilateral N-gon. Islands are clockwise numerated. Coordinates of island N1 are (x1, y1), and island N2 – (x2, y2). Your task is to find coordinates of all N islands.

     

    Input

    In the first line of input there are N, N1 and N2 (3£ N£ 150, 1£ N1,N2£N, N1¹N2separated by spaces. On the next two lines of input there are coordinates of island N1 and N2 (one pair per line) with accuracy 4digits after decimal point. Each coordinate is more than -2000000 and less than 2000000.

     

    Output

    Write N lines with coordinates for every island. Write coordinates in order of island numeration. Write answer with 6 digits after decimal point.

     

    Sample Input

    4 1 3
    1.0000 0.0000
    1.0000 2.0000
    

    Sample Output

    1.000000 0.000000
    0.000000 1.000000
    1.000000 2.000000
    2.000000 1.000000

    思路:首先旋转N1N2一定角度到圆心方向利用三角形求出圆心O,然后旋转oN1得到其他点

    #include <cstdio>
    #include <cmath>
    #include <algorithm>
    using namespace std;
    const int maxn=150;
    const double eps=1e-12;
    const double pie=acos(-1);
    double xo,yo;
    double x[maxn],y[maxn];
    int n,n1,n2;
    typedef pair<double,double> P;
    P rot(double x,double y,double angle){
        P p1;
        p1.first=y*sin(angle)+x*cos(angle);
        p1.second=y*cos(angle)-x*sin(angle);
        return p1;
    }
    int main(){
        scanf("%d%d%d",&n,&n1,&n2);n1--;n2--;
        scanf("%lf%lf%lf%lf",x+n1,y+n1,x+n2,y+n2);
        if(n1>n2)swap(n1,n2);
        P p1=P(x[n2]-x[n1],y[n2]-y[n1]);
        int gap=n2-n1;
        double angle=pie/n*gap;
        double angle2=pie/2-angle;if(angle<eps)angle+=pie;//取夹角不可能钝角或<0
        p1=rot(p1.first,p1.second,angle2);
        p1.first=-p1.first/2/cos(angle2);
        p1.second=-p1.second/2/cos(angle2);
        xo=-p1.first+x[n1],yo=-p1.second+y[n1];
        for(int i=(n1+1)%n;i!=n1;i=(i+1)%n){
            p1=rot(p1.first,p1.second,2*pie/n);
            x[i]=p1.first+xo;
            y[i]=p1.second+yo;
        }
        for(int i=0;i<n;i++){
            printf("%.6f %.6f\n",x[i],y[i]);
        }
        return 0;
    }
    

      

  • 相关阅读:
    Mac下写博客工具ecto相关资料
    重装MacOS
    Mac下写博客工具MarsEdit相关资料
    Mac下安装最新版本的Graphviz
    什么是回归分析?
    Mac 配置Charles抓https的包
    Android sdk tool android 命令参数
    判断某个端口被那个进程占用
    [置顶] 微创新时代个人崛起的方法
    xml获取配置DataTable
  • 原文地址:https://www.cnblogs.com/xuesu/p/4005598.html
Copyright © 2011-2022 走看看