zoukankan      html  css  js  c++  java
  • poj 1789 Truck History 最小生成树 prim 难度:0

    Truck History
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 19122   Accepted: 7366

    Description

    Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 

    Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 
    1/Σ(to,td)d(to,td)

    where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types. 
    Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

    Input

    The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

    Output

    For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

    Sample Input

    4
    aaaaaaa
    baaaaaa
    abaaaaa
    aabaaaa
    0
    

    Sample Output

    The highest possible quality is 1/3.
    

    Source

     
    #include <iostream>
    #include <cstring>
    
    using namespace std;
    char str[2001][9];
    int d[2001][2001];
    int mind[2001];//mind restore the min distance of the point between the tree when the point hasn't been add into
    //rather than the point in the tree to all the point not in the  tree
    bool vis[2001];
    int n;
    int ans;
    int index;
    void setd(){
        for(int i=0;i<n;i++){
            d[i][i]=0;
            for(int j=i+1;j<n;j++){
                d[i][j]=d[j][i]=0;
                for(int k=0;k<7;k++){
                    if(str[i][k]!=str[j][k]){
                        d[i][j]++;
                    }
                }
                d[j][i]=d[i][j];
            }
        }
    }
    void prim(){
        memset(mind,0x3f,sizeof(mind));
        memset(vis,0,sizeof(vis));
        index=1;
        vis[0]=true;
        ans=0;
        int s=0;
        while(index<n){
            int minnum=0x3f3f;
            int mini=0;
            for(int i=0;i<n;i++){
                if(!vis[i]&&d[s][i]<mind[i]){
                    mind[i]=d[s][i];//use i to refresh all the point
                }
                if(!vis[i]&&mind[i]<minnum){
                    minnum=mind[i];
                    mini=i;
                }
            }
            ans+=minnum;
            vis[mini]=true;
            s=mini;
            index++;
        }
    }
    int main(){
    ios::sync_with_stdio(false);
        while(cin>>n&&n){
            for(int i=0;i<n;i++){
                cin>>str[i];
            }
            setd();
            prim();
            cout<<"The highest possible quality is 1/"<<ans<<".
    ";
        }
    
        return 0;
    }
    

      

  • 相关阅读:
    高手详解SQL性能优化十条经验
    大并发大数量中的MYSQL瓶颈与NOSQL介绍
    数据库索引的作用和优点缺点
    数据库优化方法整理
    Java中Date和Calender类的使用方法
    常用正则表达式大全 (转)
    java 反射的实例
    JAVA路径问题
    jsp ${param.id}用法
    jsp base标签与meta标签学习小结
  • 原文地址:https://www.cnblogs.com/xuesu/p/4093919.html
Copyright © 2011-2022 走看看