zoukankan      html  css  js  c++  java
  • D

    D - FatMouse and Cheese

    FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

    FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

    Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

    Input

    There are several test cases. Each test case consists of a line containing two integers between 1 and 100: n and k

    n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.
    The input ends with a pair of -1's.
    OutputFor each test case output in a line the single integer giving the number of blocks of cheese collected.
    Sample Input

    3 1
    1 2 5
    10 11 6
    12 12 7
    -1 -1

    Sample Output

       37

    题意:给一个图 从(0,0) 可以垂直或水平走 每次可以走小于等于k的任意距离 但每步的值 必须大于前一步的值 在无路可走时结束(周围k范围内无比该步大的值) 求可走完的最大值

    思路:用dfs跑图 在dfs中设置cnt 用来记录上一个状态的最大值 将cnt+当前图里的值记录在二维dp数组中

    #include<bits/stdc++.h>
    using namespace std;
    int n,k,maps[101][101],dp[101][101];
    int dix[4]={0,1,0,-1};//x移动数组
    int diy[4]={1,0,-1,0};//y移动数组
    int dfs(int x,int y)
    {
        if(dp[x][y])
            return dp[x][y];//当dp数组不为0 是证明 x,y走过了
        int cnt=0;//用于记录之前值
        for(int i=0;i<4;i++)
        {
            for(int j=1;j<=k;j++)
            {
                int dx=x+dix[i]*j;
                int dy=y+diy[i]*j;
                if(dx<0||dx>=n||dy<0||dy>=n)//判断越界的条件
                    break;
                if(maps[x][y]<maps[dx][dy])
                    cnt=max(cnt,dfs(dx,dy));//更新cnt
            }
        }
        return  dp[x][y]=cnt+maps[x][y];
    }
    int main()
    {
        while(1)
        {
            cin>>n>>k;
            memset(dp,0,sizeof(dp));//初始化
            if(n==-1&&k==-1)
                break;
            for(int i=0;i<n;i++)
            {
                for(int j=0;j<n;j++)
                {
                    cin>>maps[i][j];
                }
            }
            cout<<dfs(0,0)<<endl;
        }
         return 0;
    }
  • 相关阅读:
    STL源码剖析:迭代器
    STL源码剖析:配置器
    [bzoj3940][Usaco2015 Feb]Censoring
    [bzoj2212][Poi2011]Tree Rotations
    [bzoj2733]永无乡&&[bzoj3545]Peaks
    挂个AC自动机
    [bzoj4237]稻草人
    莫比乌斯反演定理证明
    斜率优化dp学习
    备忘
  • 原文地址:https://www.cnblogs.com/xuxua/p/9278146.html
Copyright © 2011-2022 走看看