zoukankan      html  css  js  c++  java
  • E

    E - Super Jumping! Jumping! Jumping!

    Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



    The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
    Your task is to output the maximum value according to the given chessmen list.

    InputInput contains multiple test cases. Each test case is described in a line as follow:
    N value_1 value_2 …value_N
    It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
    A test case starting with 0 terminates the input and this test case is not to be processed.
    OutputFor each case, print the maximum according to rules, and one line one case.
    Sample Input

    3 1 3 2
    4 1 2 3 4
    4 3 3 2 1
    0

    Sample Output

    4
    10
    3
    题意:求最大递增字串和
    #include <iostream>
    using namespace std;
    int dp[10001],v[10001];
    int main()
    {
        int n;
        while(cin>>n,n)
        {
            for(int i=0;i<n;i++)
            {
                cin>>v[i];
                dp[i]=0;
            }
            dp[0]=v[0];
            int sum=0;
            for(int i=1;i<n;i++)
            {
                for(int j=0;j<i;j++)
                {
                    if(v[j]<v[i])
                    {
                        dp[i]=max(dp[i],dp[j]+v[i]);
                    }
                }
                dp[i]=max(dp[i],v[i]);
            }
            for(int i=0;i<n;i++)
                sum=max(sum,dp[i]);
            cout<<sum<<endl;
        }
        return 0;
    }
  • 相关阅读:
    JAVA RMI调用实战学习
    linux下关于压缩、解压相关的操作
    关于hessian接口类方法顺序及对象序列化的实战研究
    Java对象引用传递探索
    mysql 语句or效率问题
    树莓派做下载服务器 aria2 篇
    免费 cdn
    搞定迅雷固件在TP-LINK WR720N,127.0.0.1 9000 获取不到激活码
    Mware vCenter Server 识别固态硬盘为(非SSD)是什么原因?
    XXX esx.problem.syslog.nonpersistent.formatOnHost not found XXX
  • 原文地址:https://www.cnblogs.com/xuxua/p/9278353.html
Copyright © 2011-2022 走看看