zoukankan      html  css  js  c++  java
  • HDU

    The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

    InputThe input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
    OutputFor each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
    Sample Input

    1 1
    *
    3 5
    *@*@*
    **@**
    *@*@*
    1 8
    @@****@*
    5 5 
    ****@
    *@@*@
    *@**@
    @@@*@
    @@**@
    0 0 

    Sample Output

    0
    1
    2
    2
    题解:输入图 找石油发现石油就跑dfs 把八个方向的石油全部跑到 然后用平地将其替换 计数
    #include<bits/stdc++.h>
    using namespace std;
    char maps[101][101];
    int n,m;
    void dfs(int x,int y)
    {
        if(x<0||x>=n||y<0||y>=m||maps[x][y]!='@')
        {
            return ;
        }
        else
        {
            maps[x][y]='*';
            dfs(x+1,y);
            dfs(x-1,y);
            dfs(x,y+1);
            dfs(x,y-1);
            dfs(x+1,y+1);
            dfs(x+1,y-1);
            dfs(x-1,y+1);
            dfs(x-1,y-1);
        }
    }
    int main()
    {
        while(cin>>n>>m)
        {
            int sum=0;
            if(n==0||m==0)
            {
                break;
            }
            for(int i=0;i<n;i++)
            {
                for(int j=0;j<m;j++)
                {
                    cin>>maps[i][j];
                }
            }
            for(int i=0;i<n;i++)
            {
                for(int j=0;j<m;j++)
                {
                    if(maps[i][j]=='@')
                    {
                        dfs(i,j);
                        sum++;
                    }
                }
            }
            cout<<sum<<endl;
        }
        return 0;
    }
  • 相关阅读:
    修改 cmd 控制台字体、巧用 FontLink 使中英文独立设置
    非常棒的 「Sublime Text 配色/主题」与「编程字体」
    如何优雅地制作精排 ePub —— 个人电子书制作规范及基本样式表
    Simofox 2.7
    轻松绕过极域电子教室、和教师控制 Say GoodBye
    linux常用的命令
    Java Map按键(Key)排序和按值(Value)排序
    关于递归的理解以及实例
    如何去掉list里重复的数据
    快速排序的白话理解(拷贝)
  • 原文地址:https://www.cnblogs.com/xuxua/p/9546007.html
Copyright © 2011-2022 走看看