zoukankan      html  css  js  c++  java
  • [HDOJ]_PID_1004_Let the Balloon Rise

    题目:

    Problem Description
    Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
    
    This year, they decide to leave this lovely job to you.
    
    Input
    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
    
    A test case with N = 0 terminates the input and this test case is not to be processed.
    
    Output
    For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
    
    Sample Input
    5
    green
    red
    blue
    red
    red
    3
    pink
    orange
    pink
    0
    
    Sample Output
    red
    pink
    
    Author
    WU, Jiazhi
    
    Source
    ZJCPC2004
    
    Recommend
    JGShining

    代码:

    #include <iostream>
    #include <string>
    #include <map>
    #include <utility>
    
    using namespace std;
    
    int main(void) {
        int N;
    
        while (cin >> N && N != 0) {
            string word, result;
            map<string, int> word_count;
            pair<string, int> maxtimes;
            while (N-- && cin >> word) {
                ++word_count[word];
            }
    
            for (map<string, int>::const_iterator map_iter = word_count.begin();
                map_iter != word_count.end();
                ++map_iter) {
                if (map_iter->second > maxtimes.second) {
                    maxtimes.first = map_iter->first;
                    maxtimes.second = map_iter->second;
                }
            }
            cout << maxtimes.first << endl;
        }
        return 0;
    }
  • 相关阅读:
    转:Gerrit 学习
    list, set操作
    Dice chrone execise
    【转】terminal 快捷键
    python package list
    爬虫2
    爬虫 1
    django跨表联查传输数据到前端
    vue实现鼠标移入移出事件
    pycharm意外关闭导致报错Unexpected content storage modification:
  • 原文地址:https://www.cnblogs.com/xwoder/p/4596472.html
Copyright © 2011-2022 走看看