zoukankan      html  css  js  c++  java
  • Rails POJ 1363 [STL stack]

    There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track. 

    The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, ..., N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, ..., aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station. 

    Input

    The input consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1, 2, ..., N. The last line of the block contains just 0. 

    The last block consists of just one line containing 0.

    Output

    The output contains the lines corresponding to the lines with permutations in the input. A line of the output contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input. There is no line in the output corresponding to the last ``null'' block of the input.

    Sample Input

    5
    1 2 3 4 5
    5 4 1 2 3
    0
    6
    6 5 4 3 2 1
    0
    0

    Sample Output

    Yes
    No
    
    Yes
    #include <bits/stdc++.h>
    using namespace std;
    //typedef long long ll;
    using ll = long long;
    const ll inf = 4e18+10;
    const int mod = 1000000007;
    const int mx = 200010; //check the limits, dummy
    typedef pair<int, int> pa;
    const double PI = acos(-1);
    ll gcd(ll a, ll b) { return b ? gcd(b, a % b) : a; }
    #define swa(a,b) a^=b^=a^=b
    #define re(i,a,b) for(int i=(a),_=(b);i<_;i++)
    #define rb(i,a,b) for(int i=(b),_=(a);i>=_;i--)
    #define clr(a) memset(a, 0, sizeof(a))
    #define lowbit(x) ((x)&(x-1))
    #define mkp make_pair
    void sc(int& x) { scanf("%d", &x); }void sc(int64_t& x) { scanf("%lld", &x); }void sc(double& x) { scanf("%lf", &x); }void sc(char& x) { scanf(" %c", &x); }void sc(char* x) { scanf("%s", x); }
    ll  m, n,y,z,k,sum=0,ans=0,t;
    ll train[mx];
    bool flag = 0;
    int main()
    {
        ios::sync_with_stdio(false); cin.tie(0); cout.tie(0);
        while (cin>>n&&n)
        {
            while (cin >> train[1] && train[1]) {
                re(i, 2, n + 1) {
                    cin >> train[i];
                }
                flag = 1;
                ll a = 1, b = 1;
                stack<ll>s;
                while (b<=n)
                {
                    if (a == train[b])a++, b++;
                    else if (!s.empty() && s.top() == train[b])s.pop(), b++;
                    else if (a <= n)s.push(a++);
                    else {
                        flag = 0;
                        break;
                    }
                }
                if (flag)
                {
                    cout << "Yes"; cout << endl;
                }
                else cout << "No" << endl;
    
            }
            cout << endl;
        }
        
        return 0;
    }
  • 相关阅读:
    屏蔽docker镜像暴露的端口
    runtime/cgo: pthread_create failed: Resource temporarily unavailable
    用户状态bash-4.2$
    Datasnap 和mORMOT 性能对比!
    Delphi XE 时间和时间戳互转换
    Delphi XE 10.4.2 IDE 设置----【代码格式化】
    DELPHI XE 数据集合并(TFDLocalSQL)
    CXGRID 常用功能设置
    MSSQL行转列
    delphi xe 获取字符串长度(不足补位)
  • 原文地址:https://www.cnblogs.com/xxxsans/p/12717658.html
Copyright © 2011-2022 走看看