zoukankan      html  css  js  c++  java
  • 1.2.6 GPA 41.30%(477,1155)

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1155 Accepted Submission(s): 477
     
    Problem Description
    Each course grade is one of the following five letters: A, B, C, D, and F. (Note that there is no grade E.) The grade A indicates superior achievement , whereas F stands for failure. In order to calculate the GPA, the letter grades A, B, C, D, and F are assigned the following grade points, respectively: 4, 3, 2, 1, and 0.
     
    Input
    The input file will contain data for one or more test cases, one test case per line. On each line there will be one or more upper case letters, separated by blank spaces.
     
    Output
    Each line of input will result in exactly one line of output. If all upper case letters on a particular line of input came from the set {A, B, C, D, F} then the output will consist of the GPA, displayed with a precision of two decimal places. Otherwise, the message "Unknown letter grade in input" will be printed.
     
    Sample Input
    A B C D F
    B F F C C A
    D C E F
     
    Sample Output
    2.00
    1.83
    Unknown letter grade in input
     
    Author
    2006Rocky Mountain Warmup
     
    Source
    HDU “Valentines Day” Open Programming Contest 2009-02-14
     
    Recommend
    lcy
    View Code
    #include<iostream>
    #include<iomanip>
    using namespace std;

    int main()
    {
    int sign,i;
    float sum;
    char c[100000],*p;
    while(cin.getline(c,100000)){
    p=c;
    sign=0;
    sum=0;
    i=0;
    while(*p!='\0'){
    switch(*p){
    case 'A':
    sum+=4;i++;break;
    case 'B':
    sum+=3;i++;break;
    case 'C':
    sum+=2;i++;break;
    case 'D':
    sum+=1;i++;break;
    case 'F':
    sum+=0;i++;break;
    case ' ':break;
    default:
    sign=1;break;
    }
    p++;
    }
    if(sign)
    cout<<"Unknown letter grade in input"<<endl;
    else
    cout<<fixed<<setprecision(2)<<(float)sum/i<<endl;

    }
    return 0;
    }
  • 相关阅读:
    zoj 2972
    图像切割之(五)活动轮廓模型之Snake模型简单介绍
    使用和制作patch文件
    一步一步写算法(之洗牌算法)
    第3讲 数码管显示
    Oracle 11g client的安装和配置。
    StringTokenizer类的使用
    BDB (Berkeley DB)数据库简单介绍(转载)
    关于MSHTML
    C语言sizeofkeyword
  • 原文地址:https://www.cnblogs.com/yangshuo/p/2358480.html
Copyright © 2011-2022 走看看