zoukankan      html  css  js  c++  java
  • HDOJ 5289 Assignment 单调队列


    维护一个递增的和递减的单调队列


    Assignment

    Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
    Total Submission(s): 78    Accepted Submission(s): 40


    Problem Description
    Tom owns a company and he is the boss. There are n staffs which are numbered from 1 to n in this company, and every staff has a ability. Now, Tom is going to assign a special task to some staffs who were in the same group. In a group, the difference of the ability of any two staff is less than k, and their numbers are continuous. Tom want to know the number of groups like this.
     

    Input
    In the first line a number T indicates the number of test cases. Then for each case the first line contain 2 numbers n, k (1<=n<=100000, 0<k<=10^9),indicate the company has n persons, k means the maximum difference between abilities of staff in a group is less than k. The second line contains n integers:a[1],a[2],…,a[n](0<=a[i]<=10^9),indicate the i-th staff’s ability.
     

    Output
    For each test,output the number of groups.
     

    Sample Input
    2 4 2 3 1 2 4 10 5 0 3 4 5 2 1 6 7 8 9
     

    Sample Output
    5 28
    Hint
    First Sample, the satisfied groups include:[1,1]、[2,2]、[3,3]、[4,4] 、[2,3]
     

    Source
     

    Recommend
    We have carefully selected several similar problems for you:  5299 5298 5297 5296 5295 
     


    /* ***********************************************
    Author        :CKboss
    Created Time  :2015年07月21日 星期二 12时36分35秒
    File Name     :1002.cpp
    ************************************************ */
    
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <string>
    #include <cmath>
    #include <cstdlib>
    #include <vector>
    #include <queue>
    #include <set>
    #include <map>
    
    using namespace std;
    
    typedef long long int LL;
    const int maxn=100100;
    
    struct Node
    {
        int val,pos;
    };
    
    int n,K;
    int a[maxn];
    // q1 dizheng q2 dijian
    deque<Node> q1,q2;
    
    LL ans;
    
    int main()
    {
        //freopen("in.txt","r",stdin);
        //freopen("out.txt","w",stdout);
    
        int T_T;
        scanf("%d",&T_T);
        while(T_T--)
        {
            ans=0;
            while(!q1.empty()) q1.pop_back();
            while(!q2.empty()) q2.pop_back();
    
            scanf("%d%d",&n,&K);
            for(int i=0;i<n;i++) scanf("%d",a+i);
    
            int head=0;
            for(int i=0;i<n;i++)
            {
                Node node = (Node){a[i],i};
    
                /// push q1 tail dizheng
                while(!q1.empty())
                {
                    Node b = q1.back();
                    if(b.val<node.val) q1.pop_back();
                    else break;
                }
                q1.push_back(node);
    
                /// push q2 tail dijian
                while(!q2.empty())
                {
                    Node b = q2.back();
                    if(b.val>node.val) q2.pop_back();
                    else break;
                }
                q2.push_back(node);
    
                if(i==0) ans++;
                else
                {
                    /// bijiao head
                    while(true)
                    {
                        Node big = q1.front();
                        Node small = q2.front();
    
                        if(big.val-small.val<K) break;
                        else
                        {
                            if(small.pos<big.pos)
                            {
                                head=small.pos+1; q2.pop_front();
                            }
                            else
                            {
                                head=big.pos+1; q1.pop_front();
                            }
                        }
                    }
                    ans+=i-head+1;
                }
            }
    
            cout<<ans<<endl;
        }
        
        return 0;
    }




  • 相关阅读:
    XCode 7 运行 cocos2dx 2.2.6问题小节
    SerializeField和Serializable
    convert2utf8withbom
    NGUI制作字体的三种方法
    js json stringify
    nodejs npm 使用淘宝 NPM 镜像
    js url?callback=xxx xxx的介绍
    强引用 弱引用
    关于xml里的encoding
    js 历史
  • 原文地址:https://www.cnblogs.com/yangykaifa/p/6735663.html
Copyright © 2011-2022 走看看