zoukankan      html  css  js  c++  java
  • 1035. Password (20)

    题目例如以下:

    To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N (<= 1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

    Output Specification:

    For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line "There are N accounts and no account is modified" where N is the total number of accounts. However, if N is one, you must print "There is 1 account and no account is modified" instead.

    Sample Input 1:

    3
    Team000002 Rlsp0dfa
    Team000003 perfectpwd
    Team000001 R1spOdfa
    
    Sample Output 1:
    2
    Team000002 RLsp%dfa
    Team000001 R@spodfa
    
    Sample Input 2:
    1
    team110 abcdefg332
    
    Sample Output 2:
    There is 1 account and no account is modified
    
    Sample Input 3:
    2
    team110 abcdefg222
    team220 abcdefg333
    
    Sample Output 3:
    There are 2 accounts and no account is modified
    

    为了依照输入的顺序输出,我们使用vector来容纳每一条记录,每一条记录包括名称和password两项,对于每一条输入。我们定义tmp空字符串,从前到后遍历输入的字符串,对于不须要替换的字符,直接拼接到tmp尾部,假设须要替换,则把替换后的拼接到tmp尾部,最后tmp就是新password。把name和tmp压入vector作为一条记录。

    最后通过vector的规模就能够知道是否有被调整的账户,注意依照题目要求N=1和N!=1时的输出有所差异。

    #include <iostream>
    #include <string>
    #include <string.h>
    #include <stdio.h>
    #include <vector>
    
    //replace 1 (one) by @, 0 (zero) by %, l by L, and O by o.
    
    using namespace std;
    
    struct Record{
    
        string name;
        string pwd;
    
        Record(string _n, string _p) : name(_n), pwd(_p) {}
    
    };
    
    int main()
    {
        int N;
        cin >> N;
        string name,pwd;
        vector<Record> records;
        for(int i = 0; i < N; i++){
            cin >> name >> pwd;
            string tmp;
            for(int j  = 0; j < pwd.length(); j++){
                char c = pwd[j];
                switch(c){
                case '1':
                    tmp.push_back('@');
                    break;
                case '0':
                    tmp.push_back('%');
                    break;
                case 'l':
                    tmp.push_back('L');
                    break;
                case 'O':
                    tmp.push_back('o');
                    break;
                default:
                    tmp.push_back(c);
                    break;
                }
            }
            if(tmp != pwd){
                records.push_back(Record(name,tmp));
            }
        }
        if(records.size() == 0){
            if(N != 1)
                printf("There are %d accounts and no account is modified",N);
            else
                printf("There is 1 account and no account is modified");
        }else{
            cout << records.size() << endl;
            for(int i = 0; i < records.size(); i++){
                cout << records[i].name << " " << records[i].pwd << endl;
            }
        }
        return 0;
    }
    


  • 相关阅读:
    【原创】Zend Framework 2框架之MVC
    poj3101--Astronomy(分数的最小公倍数)
    【c语言】输入一个递增排序的数组的一个旋转,输出旋转数组中的最小元素
    Java中&、|、&&、||详解
    编写webpack 插件
    Babel 入门教程
    Eslint 规则说明
    npm模块之http-proxy-middleware使用教程(译)
    sass和less的几点不同
    babel的使用(关于使用async报错的问题)
  • 原文地址:https://www.cnblogs.com/yangykaifa/p/7018355.html
Copyright © 2011-2022 走看看