zoukankan      html  css  js  c++  java
  • 杭电1241 Oil Deposits

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

    Total Submission(s): 8976    Accepted Submission(s): 5245

    Problem Description
    The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
     
    Input
    The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
     
    Output
    For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
     
    Sample Input
    1 1
    *
    3 5
    *@*@*
    **@**
    *@*@*
    1 8
    @@****@*
    5 5
    ****@
    *@@*@
    *@**@
    @@@*@
    @@**@
    0 0
     
    Sample Output
    0
    1
    2
    2
     
    这是一到简单的关于深度搜索的问题.
     
    #include <iostream>
    using namespace std;
    char
    ch[105][105];
    int
    visited[105][105];   //标志位
    int
    m, n;
    int
    dir[8][2] = {-1,-1,-1,0,-1,1,0,-1,0,1,1,-1,1,0,1,1};    //每个点的八个方向(左上,上,右上,左,右,左下,下,右下)
    void
    DFS(int x1,int y1)
    {

        int
    x, y;
        for
    (int i=0; i<8; i++)
        {

            x = x1+dir[i][0];
            y = y1+dir[i][1];
            if
    ((x<0) || (y<0) || (x>=m) || (y>=n)) continue;   //判断矩阵的边界
            if
    (visited[x][y]==1 && ch[x][y]=='@')
            {

                visited[x][y] = 0;
                DFS(x,y);
            }
        }
    }


    int
    main()
    {

        int
    i, j;
        int
    count;
        while
    (cin>>m>>n &&(m||n))
        {

            count = 0;
            for
    (i=0; i<m; i++)
                for
    (j=0; j<n; j++)
                {

                    cin>>ch[i][j];
                    visited[i][j] = 1;
                }

            for
    (i=0; i<m; i++)
            {

                for
    (j=0; j<n; j++)
                {

                    if
    (visited[i][j]==1 && ch[i][j]=='@')
                    {

                        visited[i][j] = 0;    //每个被访问过的点被标记成0
                        DFS(i,j);
                        count++;
                    }
                }
            }

            cout<<count<<endl;
        }

        return
    0;
    }
  • 相关阅读:
    redis整合springboot
    安装k8s
    线程池工具类几种实现
    数据库mysql注意点及sql优化
    五年规划
    在 Ubuntu 16.04 安装ROS Kinetic 教程
    谈谈form-data请求格式 js
    C# Body为form-data file文件上传至第三方接口 http请求
    .net c# 使用form-data方式发起http请求
    使用form-data和raw作为body发起POST请求的区别
  • 原文地址:https://www.cnblogs.com/yazhou/p/3467276.html
Copyright © 2011-2022 走看看