zoukankan      html  css  js  c++  java
  • 杭电OJ第4247题 A Famous ICPC Team

      杭电OJ第4247题,A Famous ICPC Team题目链接)。

    A Famous ICPC Team

    Problem Description

    Mr. B, Mr. G, Mr. M and their coach Professor S are planning their way to Warsaw for the ACM-ICPC World Finals. Each of the four has a square-shaped suitcase with side length Ai (1 ≤ i ≤ 4) respectively. They want to pack their suitcases into a large square box. The heights of the large box as well as the four suitcases are exactly the same. So they only need to consider the large box’s side length. Of course, you should write a program to output the minimum side length of the large box, so that the four suitcases can be put into the box without overlapping.

    Input

    Each test case contains only one line containing 4 integers Ai (1 ≤ i ≤ 4, 1 ≤ Ai ≤ 1,000,000,000) indicating the side length of each suitcase.

    Output

    For each test case, display a single line containing the case number and the minimum side length of the large box required.

    Sample Input

    2 2 2 2
    2 2 2 1

    Sample Output

    Case 1: 4
    Case 2: 4

    Hint

    For the first case, all suitcases have size 2x2. So they can perfectly be packed in a 4x4 large box without wasting any space.
    For the second case, three suitcases have size 2x2 and the last one is 1x1. No matter how you rotate or move the suitcases, the side length of the large box must be at least 4.

    Source

    Fudan Local Programming Contest 2012

      解题思路:录入四个数据。取出最大的两个相加。即为大箱子的最小边长。

      C语言源代码如下:

    #include <stdio.h>
    #include <stdlib.h>
    #include <math.h>
    
    int compare( const void * a, const void * b )
    {
        return *(const int *)a - *(const int *)b;
    }
    
    int main (void)
    {
        int test_case = 0;
        int side_length[4];
        while ( scanf( "%d%d%d%d", &side_length[0], &side_length[1], &side_length[2], &side_length[3] ) != EOF )
        {
            test_case ++;
            qsort( side_length, 4, sizeof( side_length[0]), compare );
            printf( "Case %d: %d\n", test_case, (side_length[2]+side_length[3]) );
        }
        return EXIT_SUCCESS;
    }
  • 相关阅读:
    EntityFramework查询联合查询(Join,GroupJoin)
    浏览器向服务器请求页面的原理
    如何获取浏览器类型和版本
    64位Win7下32位IE无法启动问题
    jQuery 收藏
    JavaScript五种继承方式[转]
    针对模板页面的数据爬虫实现方法探讨
    ArcGISFlexSDK中关于切换地图问题(不同范围)
    NodeJS缓存文件夹遍历
    高通配置uart
  • 原文地址:https://www.cnblogs.com/yejianfei/p/2636898.html
Copyright © 2011-2022 走看看