zoukankan      html  css  js  c++  java
  • PAT A1018.Public Bike Management

    There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

    The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

    When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

    The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S3​​, we have 2 different shortest paths:

    1. PBMC -> S1​​ -> S3​​. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S1​​ and then take 5 bikes to S3​​, so that both stations will be in perfect conditions.

    2. PBMC -> S2​​ -> S3​​. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 4 numbers: Cmax​​ (≤), always an even number, is the maximum capacity of each station; N (≤), the total number of stations; Sp​​, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers Ci​​ (,) where each Ci​​ is the current number of bikes at Si​​ respectively. Then M lines follow, each contains 3 numbers: Si​​, Sj​​, and Tij​​ which describe the time Tij​​ taken to move betwen stations Si​​ and Sj​​. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of Sp​​ is adjusted to perfect.

    Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge's data guarantee that such a path is unique.

    Sample Input:

    10 3 3 5
    6 7 0
    0 1 1
    0 2 1
    0 3 3
    1 3 1
    2 3 1
    

    Sample Output:

    3 0->2->3 0

    题目大意:给定一个无向图,每个车站的完美容纳量为 cmax/2;从控制中心PBMC出发去目标车站,顺便将经过的车站也调整为完美车站。边权为路途花费时间,输出最短路径;如果有多条最短路径,则输出从中心携带出的车辆最少的,如果仍有多条,则输出返回途中携带最少的。

    思路分析:dijkstra + dfs, 回溯路径。dijkstra 寻找最短路径 dis 并 记录前缀 pre 数组。从目标车站 dfs 到 PBMC,记录最小的 minneed 和 minback 值。最后输出 path 的路径。

    #include <bits/stdc++.h>
    using namespace std;
    const int inf = 99999999;
    int G[510][510];
    int dis[510], weight[510];
    vector <int> pre[510], path, temppath;
    int Cmax, N, Sp, M;
    bool visit[510] = {false};
    int minneed = inf, minback = inf;
    
    void dfs(int v){
        temppath.push_back(v);
        if (v == 0){
            int neednum = 0, backnum = 0;
            for (int i = temppath.size() - 1; i >= 0 ; i--){
                int id  = temppath[i];
                if (weight[id] > 0){
                    backnum += weight[id];
                }else {
                    if (backnum > 0 - weight[id]){
                        backnum += weight[id];
                    }else{
                        neednum += 0 - weight[id] - backnum;
                        backnum = 0;
                    }
                }
            }
    
            if (neednum < minneed){
                minneed = neednum;
                minback = backnum;
                path = temppath;
            }else if (neednum == minneed && backnum < minback){
                minback = backnum;
                path = temppath;
            }
            temppath.pop_back();//回溯弹出
            return ;
        }
        for (int i = 0; i < pre[v].size(); i++){
            dfs(pre[v][i]);
        }
        temppath.pop_back();
    }
    
    int main(void){
        cin >> Cmax >> N >> Sp >> M;
        fill(G[0], G[0] + 510*510, inf);
        //fill(weight, weight + 510, inf);
        fill(dis, dis + 510, inf);
        for (int i = 1; i <= N; i++){
            scanf("%d", &weight[i]);
            weight[i] = weight[i] - Cmax / 2;
        }
        int tem_a, tem_b;
        for (int i = 0; i < M; i++){
            scanf("%d%d", &tem_a, &tem_b);
            scanf("%d", &G[tem_a][tem_b]);
            G[tem_b][tem_a] = G[tem_a][tem_b];
        }
    
        dis[0] = 0;
        for (int i = 0; i < N; i++){
            int u = -1, minn = inf;
            for (int j = 0; j < N; j++){
                if (visit[j] == false && minn > dis[u]){
                    u = j;
                    minn = dis[j];
                }
    
            }
    
            if (u == -1) break;
            visit[u] = true;
    
            for (int v = 0; v <= N; v++){
                if (visit[v] == false && G[u][v] != inf){
                    if (dis[u] + G[u][v] < dis[v]){
                        dis[v] = dis[u] + G[u][v];
                        pre[v].clear();
                        pre[v].push_back(u);
                    }else if(dis[u] + G[u][v] == dis[v]){
                        pre[v].push_back(u);
                    }
                }
            }
        }
    
        dfs(Sp);
    
        printf("%d 0", minneed);
        for(int i = path.size() - 2; i >= 0; i--)
            printf("->%d", path[i]);
        printf(" %d", minback);
        
        return 0;
    }

     

  • 相关阅读:
    全球覆盖 哈希
    陌上花开 模板 三维偏序
    洛谷 P4556 [Vani有约会]雨天的尾巴 /【模板】线段树合并
    熟练剖分(tree) 树形DP
    那一天她离我而去 二进制分组建图
    平凡的函数 线性筛积性函数
    wmz的数数(数状数组)
    跳一跳 概率与期望
    洛谷 P4284 [SHOI2014]概率充电器 概率与期望+换根DP
    SpringBoot手动事务参考链接
  • 原文地址:https://www.cnblogs.com/yellowzunzhi/p/11094661.html
Copyright © 2011-2022 走看看