zoukankan      html  css  js  c++  java
  • 杭电 2056

    Rectangles

    Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 14340    Accepted Submission(s): 4629


    Problem Description
    Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .
     

    Input
    Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).
     

    Output
    Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.
     

    Sample Input
    1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00 5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50
     

    Sample Output
    1.00 56.25
     

    Author
    seeyou
     

    Source
     
    这道题就是让求两个矩形重叠的面积用长乘宽即可
    这道题不难 可是我却 用了整个中午的时间搞他
    原先代码不知是哪的毛病 測试数据也对 但就是
    wa
    后来没有办法又一次换了一种算法 这才算对
    代码例如以下:

    #include<stdio.h>
    #include<string.h>
    #include<math.h>
    #include<stdlib.h>
    int cmp(const void *a,const void *b)
    {
     return *(double *)a>*(double *)b?1:-1;
    }
    int main()
    {
     double s,l,h;
     double x[4],y[4];
     double x1,y1,x2,x3,x4,y2,y3,y4;
     while(~scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&x1,&y1,&x2,&y2,&x3,&y3,&x4,&y4))
     {
      x[0]=x1;x[1]=x2;x[2]=x3;x[3]=x4;
      y[0]=y1;y[1]=y2;y[2]=y3;y[3]=y4;
      qsort(x,4,sizeof(x[0]),cmp);
      qsort(y,4,sizeof(y[0]),cmp);
      l=fabs(x2-x1)+fabs(x4-x3)-(x[3]-x[0]);
      h=fabs(y2-y1)+fabs(y4-y3)-(y[3]-y[0]);
      s=l*h;
      if(l<=0||h<=0)//推断不重叠的时候 为零由于题目有要求是精确到两位小数 
      s=0.00;
      printf("%.2lf ",s);
     }
     return 0;
    }

  • 相关阅读:
    修改input标签输入样式
    CSS3的transform 转换
    前端小知识--区分get和post请求
    JS面向对象--你真的理解闭包了吗?
    px,em,rem的区别
    傻瓜式教程--实现登录页面的验证码以及验证(VUE)
    基于RBAC权限管理的后台管理系统
    在VUE中实现打印
    关于三层架构的好文章
    RabbitMQ常用命令、管理界面
  • 原文地址:https://www.cnblogs.com/yfceshi/p/6791806.html
Copyright © 2011-2022 走看看