zoukankan      html  css  js  c++  java
  • hdu5373

    题先附上:水题,可是思路不正确,特easy超时(TLE

    The shortest problem

    Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
    Total Submission(s): 1084    Accepted Submission(s): 534


    Problem Description
    In this problem, we should solve an interesting game. At first, we have an integer n, then we begin to make some funny change. We sum up every digit of the n, then insert it to the tail of the number n, then let the new number be the interesting number n. repeat it for t times. When n=123 and t=3 then we can get 123->1236->123612->12361215.
     

    Input
    Multiple input.
    We have two integer n (0<=n<=104 ) , t(0<=t<=105) in each row.
    When n==-1 and t==-1 mean the end of input.
     

    Output
    For each input , if the final number are divisible by 11, output “Yes”, else output ”No”. without quote.
     

    Sample Input
    35 2 35 1 -1 -1
     

    Sample Output
    Case #1: Yes Case #2: No
     

    Source
     

    自己写的过程:

    连交几发都是超时。超内存;

    做题一定要注意:思路清晰。思维迅速敏捷。

    想好再写代码,不要还没思路就动手敲。什么也敲不出来。

    自己又写了一遍AC了
    同一时候。在看他的代码时学到了另外的一些东西。
    自己做题时的模版基本上写每道题时,套的库呀,另一些经常使用的宏定义,以及一些常量。自己都能够做成属于自己的模版。

    以后再写题时,就不用每次都敲一遍了。




    这道题的代码:

    #include<iostream> 
    #include<cstdio>
    #include<algorithm>
    
    using namespace std;
    
    int n;
    long t;
    
    int main()
    {
    	long js,os,i,j=0,k,m,p,q;
    	while(cin>>n>>t){
    		if(n==-1&&t==-1)break;
    		j++;
    		js=n%10+(n/100)%10+(n/10000)%10;
    		os=(n/10)%10+(n/1000)%10;
    		for(i=1;i<=t;i++){
    			k=p=q=0;
    			m=js+os;
    			while(m){
    				k++;
    				if(k%2)p+=m%10;
    				else q+=m%10;
    				m/=10;
    			}
    			if(k%2){
    				js+=q;
    				os+=p;
    				swap(js,os);
    			}
    			else {
    				js+=p;
    				os+=q;
    			}
    		}
    		if((js-os)%11)cout<<"Case #"<<j<<": No"<<endl;
    		else  cout<<"Case #"<<j<<": Yes"<<endl;
    	}
    	return 0;
    }


  • 相关阅读:
    JAVA进阶17
    JAVA进阶16
    Map in C++ Standard Template Library (STL)
    数据结构入门
    Day 17:Python 对象的相等性比较
    cmd of windows
    Nmap扫描工具
    Day16: python生产列表的使用方法
    Day 15:一些数据分析、机器学习和深度学习包和框架&&入门案例
    端口
  • 原文地址:https://www.cnblogs.com/yfceshi/p/6845634.html
Copyright © 2011-2022 走看看