zoukankan      html  css  js  c++  java
  • 杭电 3555 Bomb

    Bomb


    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
    Total Submission(s): 6609    Accepted Submission(s): 2303




    Problem Description
    The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
    Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
     


    Input
    The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.


    The input terminates by end of file marker.
     


    Output
    For each test case, output an integer indicating the final points of the power.
     


    Sample Input
    3
    1
    50
    500
     


    Sample Output
    0
    1
    15


    Hint
    From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499",

    so the answer is 15.



    第一个数位动规!

    !!!

    看代码理解的。差点儿相同懂那么点点点了。


    AC代码例如以下:

    传统模板!

    ///递推   46MS 328K
    
    #include<iostream>
    #include<cstring>
    #include<algorithm>
    #include<cmath>
    #include<cstdio>
    using namespace std;
    
    
    int main()
    {
        __int64 dp[20][3];//0表示该位数中不含49的情况数。1表示不含49但头为9的情况数。2表示含49的情况数
        int i,j;
        memset(dp,0,sizeof dp);
        dp[0][0]=1;
        for(i=1;i<=20;i++)
        {
            dp[i][0]=dp[i-1][0]*10-dp[i-1][1];
            dp[i][1]=dp[i-1][0];
            dp[i][2]=dp[i-1][2]*10+dp[i-1][1];
            //cout<<dp[i][0]<<" "<<dp[i][1]<<" "<<dp[i][2]<<endl;
        }
        int t;
        cin>>t;
        __int64 num[30];
        __int64 n;
        while(t--)
        {
            memset(num,0,sizeof num);
            cin>>n;
            n++;//这一步非常重要
            int tt=1;
            while(n)
            {
                num[tt++]=n%10;
                n/=10;
            }
            __int64 ans=0;
            int flag=0;int last=0;
            for(i=tt-1;i>=1;i--)
            {
                ans+=num[i]*dp[i-1][2];
                if(flag==1)
                    ans+=dp[i-1][0]*num[i];
                if(flag==0&&num[i]>4)
                    ans+=dp[i-1][1];
                if(num[i+1]==4&&num[i]==9)
                    flag=1;
            }
            cout<<ans<<endl;
        }
        return 0;
    }
    



    ///数位之记忆化搜索   78MS 276K
    
    
    #include<cstdio>
    #include<iostream>
    #include<cstring>
    #define mod 1000000009
    #define ll __int64
    #define M 100005
    using namespace std;
    
    ll dp[30][3];
    ll num[30];
    
    ll dfs(int pos,int statu,int limit)
    {
        int i;
        if(!pos) return statu==2;
        if(!limit&&dp[pos][statu]!=0) return dp[pos][statu];
        int end=limit?

    num[pos]:9; ll sum=0; for(i=0;i<=end;i++) { int flag=statu; if(flag==0&&i==4) flag=1; if(flag==1&&i==9) flag=2; if(flag==1&&i!=4&&i!=9) flag=0; sum+=dfs(pos-1,flag,limit&&i==end); } return limit?

    sum:(dp[pos][statu]=sum); } ll _49(ll n) { int pos=1; memset(dp,0,sizeof dp); while (n>0) { num[pos++]=n%10; n/=10; } //cout<<pos<<"~~~~~~~~~~~~~"<<endl; return dfs(pos-1,0,1); } int main() { int i,j; int t; scanf("%d",&t); while(t--) { ll n; scanf("%I64d",&n); printf("%I64d ",_49(n)); } return 0; }



  • 相关阅读:
    swift 加载 storyboard 里的UIViewController
    ios 下创建,删除文件夹的方法
    iOS ARC模式 内存管理
    UISwitch
    建立 svn 服务端
    去除NSString里面的空格
    正则表达式验证邮箱的合法性
    memcached 的安装与使用
    windows2008 IIS下配置FTP服务
    lua语法备忘录
  • 原文地址:https://www.cnblogs.com/yfceshi/p/6893226.html
Copyright © 2011-2022 走看看