zoukankan      html  css  js  c++  java
  • ZOJ Problem Set

    ZOJ Problem Set - 1002
    Fire Net

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

    A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

    Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

    The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

    The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

    Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

    The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.

    For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

    Sample input:

    4
    .X..
    ....
    XX..
    ....
    2
    XX
    .X
    3
    .X.
    X.X
    .X.
    3
    ...
    .XX
    .XX
    4
    ....
    ....
    ....
    ....
    0
    

    Sample output:

    5
    1
    5
    2
    4
    思路:在地图上 X 表示墙 , O 表示放置的炮塔 , . 表示可以放置炮塔
       两个炮塔在没有墙壁分割的情况下不能放在同一行或者同一列。
       
       对地图上每个点都需要尝试放置炮塔,放炮塔时需要考虑周围炮塔的影响。
       地图位置编号 , 递归深搜找出结果
       
       由于探测位置时行列递增的所以只需要向左向上查看能不能放置
    #include <iostream>
    #include <algorithm>
    #include <cstring>
    
    using namespace std ; 
    
    #define maxn 10
    int n ; 
    int result ;
    char map[maxn][maxn] ; 
    char str[maxn] ;     
    
    
    bool canput(int x , int y){
        
        for(int i=x-1 ; i>=0 ;  i--){
    
            if(map[i][y] == 'X'){
                break ; 
            }
            if(map[i][y] == 'O'){
                return false;
            }
        }
    
        for(int i=y-1 ; i>=0 ; i--){
            if(map[x][i] == 'X'){
                break ; 
            }
            if(map[x][i] == 'O'){
                return false ; 
            }
        }
        return true ; 
    }
    
    void DFS(int pos , int step){
        int x = pos / n ; 
        int y = pos % n ; 
    
        if(pos == n*n){
            result = max(result , step) ; 
            return; 
        }
    
        if(map[x][y] == '.' && canput(x , y)){
            map[x][y] = 'O' ; 
            DFS(pos+1 , step+1) ;
            map[x][y] = '.' ;  
        }
        DFS(pos+1 , step) ; 
    }
    
    int main(){
        
        while(cin >> n && n != 0 ){
            for(int i=0 ; i<n ; i++){
                cin >> str ; 
                for(int j=0 ; j<strlen(str) ; j++){
                    map[i][j] = str[j] ; 
                }
            }
    
            result = 0 ; 
            DFS(0 , 0) ; 
    
            cout << result << endl ; 
        }
        return 0 ; 
    }

  • 相关阅读:
    Jquery实现无刷新DropDownList联动
    Mvc 提交表单的4种方法全程详解
    Sql Like 通配符 模糊查询技巧及特殊字符
    SQL 语句递归查询 With AS 查找所有子节点
    最常用的五类CSS选择器
    取出分组后每组的第一条记录(不用group by)按时间排序
    SpringCloud中接收application/json格式的post请求参数并转化为实体类
    SpringCloud负载均衡笔记
    iview-admin打包笔记
    SpringCloud之最大的坑
  • 原文地址:https://www.cnblogs.com/yi-ye-zhi-qiu/p/9137945.html
Copyright © 2011-2022 走看看