zoukankan      html  css  js  c++  java
  • ZOJ Problem Set

    ZOJ Problem Set - 1004
    Anagrams by Stack

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    How can anagrams result from sequences of stack operations? There are two sequences of stack operators which can convert TROT to TORT:

    [
    i i i i o o o o
    i o i i o o i o
    ]
    

    where i stands for Push and o stands for Pop. Your program should, given pairs of words produce sequences of stack operations which convert the first word to the second.

    Input

    The input will consist of several lines of input. The first line of each pair of input lines is to be considered as a source word (which does not include the end-of-line character). The second line (again, not including the end-of-line character) of each pair is a target word. The end of input is marked by end of file.

    Output

    For each input pair, your program should produce a sorted list of valid sequences of i and o which produce the target word from the source word. Each list should be delimited by

    [
    ]
    

    and the sequences should be printed in "dictionary order". Within each sequence, each i and o is followed by a single space and each sequence is terminated by a new line.

    Process

    A stack is a data storage and retrieval structure permitting two operations:

    Push - to insert an item and Pop - to retrieve the most recently pushed item

    We will use the symbol i (in) for push and o (out) for pop operations for an initially empty stack of characters. Given an input word, some sequences of push and pop operations are valid in that every character of the word is both pushed and popped, and furthermore, no attempt is ever made to pop the empty stack. For example, if the word FOO is input, then the sequence:

    i i o i o o is valid, but
    i i o is not (it's too short), neither is
    i i o o o i (there's an illegal pop of an empty stack)

    Valid sequences yield rearrangements of the letters in an input word. For example, the input word FOO and the sequence i i o i o o produce the anagram OOF. So also would the sequence i i i o o o. You are to write a program to input pairs of words and output all the valid sequences of i and o which will produce the second member of each pair from the first.

    Sample Input

    madam
    adamm
    bahama
    bahama
    long
    short
    eric
    rice
    

    Sample Output

    [
    i i i i o o o i o o 
    i i i i o o o o i o 
    i i o i o i o i o o 
    i i o i o i o o i o 
    ]
    [
    i o i i i o o i i o o o 
    i o i i i o o o i o i o 
    i o i o i o i i i o o o 
    i o i o i o i o i o i o 
    ]
    [
    ]
    [
    i i o i o i o o 
    ]
    题意:i 表示进栈 , o 表示出栈.构造出所要求输出的单词的进出栈顺序
    主要算法:回溯法(递归思想)
    #include <iostream>
    #include <algorithm>
    #include <vector>
    #include <stack>
    #include <string>
    
    using namespace std ; 
    
    stack <char>build ; 
    vector <char> operato ; 
    string a , b ; 
    int len ; 
    
    void DFS(int ipush , int ipop){
    
        if(ipush == len && ipop == len){
            for(int i=0 ; i<operato.size() ; i++){
                cout << operato[i] << " " ; 
            }
            cout << endl ; 
            return;
        }
    
        if(ipush+1 <= len ){
            build.push(a[ipush]) ; 
            operato.push_back('i') ; 
            DFS(ipush+1 , ipop) ; 
            build.pop() ; 
            operato.pop_back() ; 
        }
    
        if(ipop+1<=ipush && ipop+1 <=len && build.top() == b[ipop]){
            char turn = build.top() ; 
            build.pop() ; 
            operato.push_back('o') ; 
            DFS(ipush , ipop+1) ; 
            operato.pop_back() ; 
            build.push(turn) ; 
        }
        return;
    }
    
    int main(){
    
        while(cin >> a >> b){
            len = a.length() ; 
    
            cout << '[' << endl ; 
            DFS(0,0) ; 
            cout << ']' << endl ; 
        }
        return 0 ; 
    }
    #include <iostream>
    #include <stack>
    #include <map>
    #include <set>
    #include <queue>
    #include <vector>
    #include <list>
    using namespace std;
    string a,b;//源单词与目标单词
    stack<char> build;//构造目标字符串
    vector<char> operate;//记录出入栈操作
    int length;
    void dfs(int ipush,int ipop)//形参ipush计录入栈操作次数,形参ipop计录出栈操作次数
    {
        if(ipush==length&&ipop==length)//如果入栈操作次数和出栈·操作·次数·刚好·等于·字符串·长度·时,则·目标字符串构造完成,输出操作序列
        {
            for(int i=0;i<operate.size();i++)
                cout<<operate[i]<<" ";
                cout<<endl;
        }
        //入栈操作
        if(ipush+1<=length)
        {
            build.push(a[ipush]);//将当前字符入栈
            operate.push_back('i');//计录入栈操作
            dfs(ipush+1,ipop);//搜素下一个位置
            build.pop();//恢复好刚刚入栈的字符,便于下一个搜索
            operate.pop_back();//恢复入栈操作
        }
        //出栈操作
        if(ipop+1<=ipush&&ipop+1<=length&&build.top()==b[ipop])
        {
            char tc=build.top();
            build.pop();//将当前字符出栈
            operate.push_back('o');//计录出栈操作
            dfs(ipush,ipop+1);//搜索下一个位置
            build.push(tc);//恢复好刚刚出栈的字符,便于下一个搜索
            operate.pop_back();//恢复出栈操作
        }
    }
    int main()
    {
        while(cin>>a>>b)
        {
            length=a.length();
            cout<<"["<<endl;
            dfs(0,0);
            cout<<"]"<<endl;
        }
        return 0;
    }
  • 相关阅读:
    JS统计还可以输入多少字数,用于向输入者提示信息
    php系统 骑士cms(74cms)个人版 整合UC
    win7下使用wamp server 使用PHP5.3配置Zend guard loader 注意事项,失败
    linux crontab定时任务运行shell脚本(shell执行sql文件)
    POJ 1179 Polygon
    POJ 1189 钉子和小球
    HDU 3788 ZOJ问题
    POJ 1191 棋盘分割【区间类DP】
    POJ 1338 Ugly Numbers
    假期学习第一步之......学习堆排序
  • 原文地址:https://www.cnblogs.com/yi-ye-zhi-qiu/p/9141580.html
Copyright © 2011-2022 走看看