zoukankan      html  css  js  c++  java
  • POJ 2250 (LCS,经典输出LCS序列 dfs)

    题目链接:

    http://poj.org/problem?id=2250

    Compromise
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 9284   Accepted: 3972   Special Judge

    Description

    In a few months the European Currency Union will become a reality. However, to join the club, the Maastricht criteria must be fulfilled, and this is not a trivial task for the countries (maybe except for Luxembourg). To enforce that Germany will fulfill the criteria, our government has so many wonderful options (raise taxes, sell stocks, revalue the gold reserves,...) that it is really hard to choose what to do.

    Therefore the German government requires a program for the following task:
    Two politicians each enter their proposal of what to do. The computer then outputs the longest common subsequence of words that occurs in both proposals. As you can see, this is a totally fair compromise (after all, a common sequence of words is something what both people have in mind).

    Your country needs this program, so your job is to write it for us.

    Input

    The input will contain several test cases.
    Each test case consists of two texts. Each text is given as a sequence of lower-case words, separated by whitespace, but with no punctuation. Words will be less than 30 characters long. Both texts will contain less than 100 words and will be terminated by a line containing a single '#'.
    Input is terminated by end of file.

    Output

    For each test case, print the longest common subsequence of words occuring in the two texts. If there is more than one such sequence, any one is acceptable. Separate the words by one blank. After the last word, output a newline character.

    Sample Input

    die einkommen der landwirte
    sind fuer die abgeordneten ein buch mit sieben siegeln
    um dem abzuhelfen
    muessen dringend alle subventionsgesetze verbessert werden
    #
    die steuern auf vermoegen und einkommen
    sollten nach meinung der abgeordneten
    nachdruecklich erhoben werden
    dazu muessen die kontrollbefugnisse der finanzbehoerden
    dringend verbessert werden
    #
    

    Sample Output

    die einkommen der abgeordneten muessen dringend verbessert werden
    

    Source

    分析:
    经典的LCS问题,重点是采用DFS输出此LCS序列中的一个
    注意输入两个序列的方式,学习了
    注意输入序列的下标从1开始
    注意DFS要先递归到最后再输出序列
    注意dp的初始化,直接memset就可以
    代码如下:
     
    代码如下;
    #include<cstring>
    #include<cstdio>
    #include<string>
    #include<iostream>
    #include<algorithm>
    #define max_v 1005
    using namespace std;
    string x[max_v],y[max_v];
    int dp[max_v][max_v];
    int l1,l2;
    int dfs(int i,int j)
    {
        if(i==0||j==0)
            return 0 ;
        if(x[i]==y[j])//来自左上角
        {
            dfs(i-1,j-1);
            cout<<x[i]<<" ";//先递归到最后再输出,,这样就是顺序的
        }
        else
        {
            if(dp[i-1][j]>dp[i][j-1])//来自上面
            {
                dfs(i-1,j);
            }
            else//来自左边
            {
                dfs(i,j-1);
            }
        }
        return 0;
    }
    int main()
    {
        string s;
        while(cin>>s)
        {
            l1=l2=0;
            if(s!="#")
            {
                x[++l1]=s;
                while(cin>>s&&s!="#")
                {
                    x[++l1]=s;
                }
            }
            while(cin>>s&&s!="#")
            {
                y[++l2]=s;
            }
            memset(dp,0,sizeof(dp));
            for(int i=1; i<=l1; i++)
            {
                for(int j=1; j<=l2; j++)
                {
                    if(x[i]==y[j])
                    {
                        dp[i][j]=dp[i-1][j-1]+1;
                    }
                    else
                    {
                        dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
                    }
                }
            }
            dfs(l1,l2);
            cout<<endl;
        }
        return 0;
    }
  • 相关阅读:
    「CF722E Research Rover」
    「Luogu P4062 [Code+#1]Yazid 的新生舞会」
    【cf比赛记录】Codeforces Round #613 (Div. 2)
    【cf比赛记录】Educational Codeforces Round 78 (Rated for Div. 2)
    【cf补题记录】Codeforces Round #608 (Div. 2)
    【cf补题记录】Codeforces Round #607 (Div. 2)
    【cf比赛记录】Codeforces Round #606 (Div. 2, based on Technocup 2020 Elimination Round 4)
    【cf比赛记录】Codeforces Round #605 (Div. 3)
    【Codeforces】B. Div Times Mod
    【牛客练习赛53】A-超越学姐爱字符串
  • 原文地址:https://www.cnblogs.com/yinbiao/p/9067766.html
Copyright © 2011-2022 走看看