zoukankan      html  css  js  c++  java
  • HDU 1312 Red and Black(最简单也是最经典的搜索)

    传送门:

    http://acm.hdu.edu.cn/showproblem.php?pid=1312

    Red and Black

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 25397    Accepted Submission(s): 15306


    Problem Description
    There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

    Write a program to count the number of black tiles which he can reach by repeating the moves described above.
     
    Input
    The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

    There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

    '.' - a black tile
    '#' - a red tile
    '@' - a man on a black tile(appears exactly once in a data set)
     
    Output
    For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
     
    Sample Input
    6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
     
    Sample Output
    45 59 6 13
     
    Source
     
    Recommend
    Eddy   |   We have carefully selected several similar problems for you:  1372 1242 1253 1240 1072 
     
    分析:
    只能上下左右四个方向走,问你可以走的块最多是多少?#不能走
    小技巧:走过的地方字符就变为#
     
    先用dfs写一下,有时间再用bfs写
    code:
    #include<bits/stdc++.h>
    using namespace std;
    #define max_v 25
    char G[max_v][max_v];
    int n,m;
    int sx,sy;
    int step;
    int dir[4][2]={0,1,1,0,0,-1,-1,0};
    void dfs(int x,int y)
    {
        int xx,yy;
        for(int i=0;i<4;i++)
        {
            xx=x+dir[i][0];
            yy=y+dir[i][1];
            if(xx>=0&&xx<n&&yy>=0&&yy<m&&G[xx][yy]!='#')
            {
                step++;
                G[xx][yy]='#';
                dfs(xx,yy);
            }
        }
    }
    int main()
    {
        while(~scanf("%d %d",&m,&n))
        {
            if(n==0&&m==0)
                break;
            getchar();
            for(int i=0;i<n;i++)
            {
                for(int j=0;j<m;j++)
                {
                    cin>>G[i][j];
                    if(G[i][j]=='@')
                    {
                        sx=i;
                        sy=j;
                    }
                }
            }
            step=1;
            G[sx][sy]='#';
            dfs(sx,sy);
            cout<<step<<endl;
        }
        return 0;
    }
     
  • 相关阅读:
    自我理解:const char*, char const* and char *const
    获取任意控件的ID或窗口句柄
    Webmax 2.0开启无限量下载
    dotLucene搜索加入中文分词
    SQL SERVER获得指定表的主键
    LogExplore应用(ms sql server事物分析、数据恢复工具)[转载]
    电脑病之一
    查找数据库中记录数大于N的表
    视图
    获取生日提醒数据
  • 原文地址:https://www.cnblogs.com/yinbiao/p/9350674.html
Copyright © 2011-2022 走看看