zoukankan      html  css  js  c++  java
  • ACM-ICPC国际大学生程序设计竞赛北京赛区(2016)网络赛 A Simple Job

    描述

    Institute of Computational Linguistics (ICL), Peking University is an interdisciplinary institute of science and liberal arts, it focuses primarily on the fundamental researches and applications of language information processing. The research of ICL covers a wide range of areas, including Chinese syntax, language parsing, computational lexicography, semantic dictionaries, computational semantics and application systems.

    Professor X is working for ICL. His little daughter Jane is 9 years old and has learned something about programming. She is always very interested in her daddy's research. During this summer vacation, she took a free programming and algorithm course for kids provided by the School of EECS, Peking University. When the course was finished, she said to Professor X: "Daddy, I just learned a lot of fancy algorithms. Now I can help you! Please give me something to research on!" Professor X laughed and said:"Ok, let's start from a simple job. I will give you a lot of text, you should tell me which phrase is most frequently used in the text."

    Please help Jane to write a program to do the job.

    输入

    There are no more than 20 test cases.

    In each case, there are one or more lines of text ended by a line of "####". The text includes words, spaces, ','s and '.'s. A word consists of only lowercase letters. Two adjacent words make a "phrase". Two words which there are just one or more spaces between them are considered adjacent. No word is split across two lines and two words which belong to different lines can't form a phrase. Two phrases which the only difference between them is the number of spaces, are considered the same.

    Please note that the maximum length of a line is 500 characters, and there are at most 50 lines in a test case. It's guaranteed that there are at least 1 phrase in each test case.

    输出

    For each test case, print the most frequently used phrase and the number of times it appears, separated by a ':' . If there are more than one choice, print the one which has the smallest dictionary order. Please note that if there are more than one spaces between the two words of a phrase, just keep one space.

    样例输入

    above,all ,above all good at good at good
    at good at above all me this is
    ####
    world hello ok
    ####

    样例输出

    at good:3
    hello ok:1
    题解没有QAQ
    #include<stdio.h>
    //#include<bits/stdc++.h>
    #include<string.h>
    #include<iostream>
    #include<math.h>
    #include<sstream>
    #include<set>
    #include<queue>
    #include<map>
    #include<vector>
    #include<algorithm>
    #include<limits.h>
    #define inf 0x3fffffff
    #define INF 0x3f3f3f3f
    #define lson l,m,rt<<1
    #define rson m+1,r,rt<<1|1
    #define LL long long
    #define ULL unsigned long long
    using namespace std;
    char ss[1000];
    map<string,int>q;
    map<string,int>::iterator it;
    int main()
    {
        ios::sync_with_stdio(false);
        cin.tie(0),cout.tie(0);
        string s;
        while(cin.getline(ss,sizeof(ss)))
        {
            if(ss[0]=='#')
            {
                string x;
                int p=0,cnt=0,p1=0;
                for(int i=0;i<s.size();i++)
                {
                    if(s[i]==' ')
                    {
                        cnt++;
                        p1=p;
                        p=i;
                    }
                    else if(s[i]==',')
                    {
                        cnt++;
                        if(cnt==1)
                        {
                            x="";
                            cnt=0;
                        }
                        p=i;
                        p1=i;
                    }
                    if(s[i]!=','&&cnt!=2)
                    {
                        x+=s[i];
                    }
                    if(cnt>=2)
                    {
                        q[x]++;
                        cnt=0;
                        if(s[i]==' ') i=p1;
                        x="";
                    }
                }
                int Max=0;
                string y;
                for(it=q.begin();it!=q.end();it++)
                {
                    if(it->second>Max) y=it->first,Max=it->second;
                }
                cout<<y<<":"<<q[y]<<endl;
                q.clear();
                s="";
            }
            else
            {
                for(int i=0;i<strlen(ss);i++)
                {
                    if(ss[i]=='.') ss[i]=',';
                    if(ss[i]==' ')
                    {
                        if(ss[i-1]==','||ss[i+1]==','||ss[i-1]==' ')
                            continue;
                    }
                    s+=ss[i];
                }
                s+=',';
            }
        }
        return 0;
    }
    

      

  • 相关阅读:
    Visual Studio 2010单元测试(2)--运行测试并查看代码覆盖率
    实用设计模式之观察者模式
    并查集简单题pku1611
    HDU 4534 郑厂长系列故事——新闻净化(AC自动机+DP)
    求 小于 n 的 质数 几种方式
    MySQL数据库高并发优化配置
    MySQL 对于千万级的大表要怎么优化?
    mysql数据库优化总结
    php 正则表达式怎么匹配标签里面的style?
    MySql数据库优化可以从哪几个方面进行?
  • 原文地址:https://www.cnblogs.com/yinghualuowu/p/5903637.html
Copyright © 2011-2022 走看看