Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The
input contains several test cases. Each test case contains a positive
integer N(1<=N<=120) which is mentioned above. The input is
terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4
10
20
Sample Output
5
42
627
Author
Ignatius.L
题目描述:把一个整数拆分成一个或多个的整数之和,问总共有多少种拆分方法?
问题的解决:多个整数可以是0,1,2,3、、、n,设这些整数为i,则所需要i的最多的个数为 n/i;母函数写法

1 #include <stdio.h> 2 #include <string.h> 3 4 #define MAX_INDEX 120 5 int main() 6 { 7 int n, i, j, k; 8 //母函数所需的两个一维数组 9 int c1[MAX_INDEX+1], c2[MAX_INDEX+1]; 10 while( scanf( "%d",&n ) != EOF ) 11 { 12 memset(c1,0,sizeof(c1)); 13 memset(c2,0,sizeof(c2)); 14 for( i = 0; i <= n; i++ ) 15 c1[i] = 1; 16 for( i = 2; i <= n; i++ ) 17 { 18 for( j = 0; j <= n; j++ ) 19 for( k = 0; k + j <= n; k += i ) 20 c2[k+j] += c1[j]; 21 for( j = 0; j <= n; j++ ) 22 { 23 c1[j] = c2[j]; 24 c2[j] = 0; 25 } 26 } 27 printf( "%d\n", c1[n] ); 28 } 29 return 0; 30 }