zoukankan      html  css  js  c++  java
  • Twelves Monkeys (multiset解法 141

    Twelves Monkeys

    Time Limit: 5 Seconds      Memory Limit: 32768 KB

    James Cole is a convicted criminal living beneath a post-apocalyptic Philadelphia. Many years ago, the Earth's surface had been contaminated by a virus so deadly that it forced the survivors to move underground. In the years that followed, scientists had engineered an imprecise form of time travel. To earn a pardon, Cole allows scientists to send him on dangerous missions to the past to collect information on the virus, thought to have been released by a terrorist organization known as the Army of the Twelve Monkeys.

    The time travel is powerful so that sicentists can send Cole from year x[i] back to year y[i]. Eventually, Cole finds that Goines is the founder of the Army of the Twelve Monkeys, and set out in search of him. When they find and confront him, however, Goines denies any involvement with the viruscan. After that, Cole goes back and tells scientists what he knew. He wants to quit the mission to enjoy life. He wants to go back to the any year before current year, but scientists only allow him to use time travel once. In case of failure, Cole will find at least one route for backup. Please help him to calculate how many years he can go with at least two routes.

    Input

    The input file contains multiple test cases.

    The first line contains three integers n,m,q(1≤ n ≤ 50000, 1≤ m ≤ 50000, 1≤ q ≤ 50000), indicating the maximum year, the number of time travel path and the number of queries.

    The following m lines contains two integers x,y(1≤ y x ≤ 50000) indicating Cole can travel from year x to year y.

    The following q lines contains one integers p(1≤ p ≤ n) indicating the year Cole is at now

    Output

    For each test case, you should output one line, contain a number which is the total number of the year Cole can go.

    Sample Input

    9 3 3
    9 1
    6 1
    4 1
    6
    7
    2
    

    Sample Output

    5
    0
    1
    

    Hint

    6 can go back to 1 for two route. One is 6-1, the other is 6-7-8-9-1.6 can go back to 2 for two route. One is 6-1-2, the other is 6-7-8-9-1-2.


    题意:n个时刻点。m次时光穿梭,告诉每次穿梭的起点和终点,q次询问,每次询问t时刻t之前有多少时刻点是能够通过两种不同的路径到达的。

    思路:对于询问的时刻t能够顺时间向后推移到t+1,t+2。t+3.。。

    。。。那么t时刻及以后的时刻的穿梭都是可能的,把他们能穿梭到的时刻插入multiset,假设multiset里有至少两个元素的值大于等于t,则该时刻t存在解。

    另外注意的是,询问的时刻点靠前的都能够到达靠后的,所以我们得从后往前求解。

    代码:

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <cmath>
    #include <string>
    #include <map>
    #include <stack>
    #include <vector>
    #include <set>
    #include <queue>
    #pragma comment (linker,"/STACK:102400000,102400000")
    #define pi acos(-1.0)
    #define eps 1e-6
    #define lson rt<<1,l,mid
    #define rson rt<<1|1,mid+1,r
    #define FRE(i,a,b)  for(i = a; i <= b; i++)
    #define FREE(i,a,b) for(i = a; i >= b; i--)
    #define FRL(i,a,b)  for(i = a; i < b; i++)
    #define FRLL(i,a,b) for(i = a; i > b; i--)
    #define mem(t, v)   memset ((t) , v, sizeof(t))
    #define sf(n)       scanf("%d", &n)
    #define sff(a,b)    scanf("%d %d", &a, &b)
    #define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
    #define pf          printf
    #define DBG         pf("Hi
    ")
    typedef long long ll;
    using namespace std;
    
    #define INF 0x3f3f3f3f
    #define mod 1000000009
    const int maxn = 1005;
    const int MAXN = 1e5+10;
    
    struct Edge
    {
        int u,v;
    }edge[MAXN];
    
    struct Node
    {
        int d,id;
    }node[MAXN];
    
    int cmp1(Edge e1,Edge e2)
    {
        return e1.u<e2.u;
    }
    
    int cmp2(Node node1,Node node2)
    {
        return node1.d<node2.d;
    }
    
    multiset<int> S;
    
    int n,m,q;
    int ans[MAXN],a[maxn];
    
    void solve()
    {
        int i;
        S.clear();
        sort(edge,edge+m,cmp1); //两个都依照日期从小到大排序
        sort(node,node+q,cmp2);
        int pos=m-1;
        for (i=q-1;i>=0;i--)    //从后往前扫,由于前面的时刻能够顺时间到达后面的
        {
            int day=node[i].d;
            int cnt=0;
            while (pos>=0&&edge[pos].u>=day)
            {
                S.insert(edge[pos].v);
                pos--;
            }
            for (multiset<int>::iterator it=S.begin();it!=S.end();it++)
            {
                a[cnt++]=*(it);
                if (cnt>=2) break;
            }
            if (cnt>=2&&a[1]<=day)
                ans[node[i].id]=day-a[1];
            else
                ans[node[i].id]=0;
        }
        for (i=0;i<q;i++)
            pf("%d
    ",ans[i]);
        return ;
    }
    
    int main()
    {
    #ifndef ONLINE_JUDGE
        freopen("C:/Users/lyf/Desktop/IN.txt","r",stdin);
    #endif
        int i,j,t;
        while (~sfff(n,m,q))
        {
            for (i=0;i<m;i++)
                sff(edge[i].u,edge[i].v);
            for (i=0;i<q;i++)
            {
                sf(node[i].d);
                node[i].id=i;
            }
            solve();
        }
        return 0;
    }
    



  • 相关阅读:
    最大流问题
    最短路-Floyd算法和Dijkstra算法
    最小生成树-Prim算法
    最小生成树-Kruskal算法
    MP and KMP
    导出excel表格并合并单元格(不按模板导出)
    导出excel表格(按模板导出)
    datatables和template列表查询分页单元格合并
    datatables的使用
    js对象的使用
  • 原文地址:https://www.cnblogs.com/yjbjingcha/p/6793012.html
Copyright © 2011-2022 走看看