zoukankan      html  css  js  c++  java
  • Dawn-K's water(完全背包)

    Dawn-K recently discovered a very magical phenomenon in the supermarket of Northeastern University: The large package is not necessarily more expensive than the small package.

    On this day, Dawn-K came to the supermarket to buy mineral water, he found that there are nn types of mineral water, and he already knew the price pp and the weight cc (kg) of each type of mineral water. Now Dawn-K wants to know the least money aa he needs to buy no less than mm kilograms of mineral water and the actual weight bb of mineral water he will get. Please help him to calculate them.

    Input

    The input consists of multiple test cases, each test case starts with a number nn (1 le n le 10^31n103) -- the number of types, and mm (1 le m le 10^41m104) -- the least kilograms of water he needs to buy. For each set of test cases, the sum of nn does not exceed 5e45e4.

    Then followed n lines with each line two integers pp (1 le p le 10^91p109) -- the price of this type, and cc (1 le c le 10^41c104) -- the weight of water this type contains.

    Output

    For each test case, you should output one line contains the minimum cost aa and the weight of water Dawn-K will get bb. If this minimum cost corresponds different solution, output the maximum weight he can get.

    (The answer aa is between 11 and 10^9109, and the answer bb is between 11 and 10^4104)

    样例输入

    3 3
    2 1
    3 1
    1 1
    3 5
    2 3
    1 2
    3 3
    

    样例输出

    3 3
    3 6
    做了好几遍没过,卡long long 了,一定注意数据范围
    #include<bits/stdc++.h>
    using namespace std;
    typedef long long ll;
    const int maxn=2e4+5;
    int p[maxn],w[maxn];
    ll dp[maxn];
    int main()
    {
        int n,m;
        while(cin>>n>>m)
        {
            for(int i=1;i<=n;i++)
                cin>>p[i]>>w[i];
            for(int i=1;i<maxn;i++)
                dp[i]=1e18;
            dp[0]=0;
            for(int i=1;i<=n;i++){
                for(int j=w[i];j<maxn;j++){
                    dp[j]=min(dp[j],dp[j-w[i]]+p[i]);
                }
            }
            ll a=1e18,b=0;
            for(int i=m;i<maxn;i++){
                if(dp[i]<=a){
                    a=dp[i];
                    b=i;
                }
            }
            cout<<a<<" "<<b<<endl;
        }
        return 0;
    }
  • 相关阅读:
    导航控制器生产,push,pop,root,index
    DNSserver内置笔记本
    解决“Dynamic Web Module 3.0 requires Java 1.6 or newer.”错误
    ssh配置连接
    在UITouch事件中画圆圈-iOS8 Swift基础教程
    iOS之UITableViewCell左右滑动效果
    iOS UIView非常用方法及属性详解
    IOS用CGContextRef画各种图形(文字、圆、直线、弧线、矩形、扇形、椭圆、三角形、圆角矩形、贝塞尔曲线、图片)
    UIColor,CGColor,CIColor三者的区别和联系
    iOS中正确的截屏姿势
  • 原文地址:https://www.cnblogs.com/ylrwj/p/11930481.html
Copyright © 2011-2022 走看看