zoukankan      html  css  js  c++  java
  • 【学习笔记】〖九度OJ〗题目1437:To Fill or Not to Fill

    题目1437:To Fill or Not to Fill

    时间限制:1 秒

    内存限制:128 兆

    特殊判题:

    提交:719

    解决:163

    题目描述:

    With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

    输入:

    For each case, the first line contains 4 positive numbers: Cmax (<= 100), the maximum capacity of the tank; D (<=30000), the distance between Hangzhou and the destination city; Davg (<=20), the average distance per unit gas that the car can run; and N (<= 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: Pi, the unit gas price, and Di (<=D), the distance between this station and Hangzhou, for i=1,...N. All the numbers in a line are separated by a space.

    输出:

    For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print "The maximum travel distance = X" where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

    样例输入:
    50 1300 12 8
    6.00 1250
    7.00 600
    7.00 150
    7.10 0
    7.20 200
    7.50 400
    7.30 1000
    6.85 300
    50 1300 12 2
    7.10 0
    7.00 600
    样例输出:
    749.17
    The maximum travel distance = 1200.00
    来源:
    2012年浙江大学计算机及软件工程研究生机试真题
    利用贪心法,每次走一站,记录当前距离,当前油箱油量。

    贪心策略:

    在当前站向前看,如果一次可行驶最大距离内有较便宜的加油站,加油量到可以行驶到第一个最便宜的站点

    如果最大距离以内当前站最便宜,加满油

    如果任意一站到下一站的距离超过最大距离,则无法到达

    特殊情况:初始站点没有加油站



    #include<iostream>
    #include<algorithm>
    #include<iomanip>
    using namespace std;
     
    class Station
    {
    public:
        int dis;
        float pri;
        Station()
        {
            dis = 0;
            pri = 0;
        }
     
    };
     
    bool cmp(Station a, Station b)
    {
        return a.dis < b.dis;
    }
     
    Station s[501];
    float res;//结果
     
     
    int main()
    {
         
        int cmax, d,  n, i, j;
        float davg;
        int maxDis;//加满一次行驶最大距离
     
         
        float res = 0;
     
        while(cin >> cmax)
        {
            res = 0;
            cin >> d >> davg >> n;
     
            maxDis = cmax * davg;
     
            for (i=0; i<n; i++)
            {
                cin >> s[i].pri >> s[i].dis;
            }
            s[n].dis = d;//去特殊化
     
            sort(s, s+n, cmp);
     
            if (s[0].dis != 0)
            {
                cout << "The maximum travel distance = 0.00" << endl;
                continue;
            }
     
            int curPos=0;
            float curOil=0;//当前距离、油箱剩油
     
            for (i=0; i<n ; i++)//每次一站
            {
                curPos = s[i].dis;
                //无法到达终点
                if (curPos + maxDis < s[i+1].dis)
                {
                    cout << "The maximum travel distance = ";
                    cout << setiosflags(ios::fixed) << setprecision(2) << curPos+maxDis +0.0<< endl;
                    break;
                }
                 
                //减掉中间行驶耗油
                if (i>0)
                {
                    curOil = curOil - (s[i].dis - s[i-1].dis)/davg;
                }
                 
                //如果最大距离内有较便宜
                int curDis = 0;
                bool isCheap = false;
                for (j=i+1; j<n; j++)
                {               
                    curDis = s[j].dis - s[i].dis;
                    if (curDis>maxDis)//如果没有
                    {
                        //res += (cmax - curOil)*s[i].pri;
                        //curOil = cmax;
                        break;
                    }
                    if (s[j].pri<s[i].pri)//有行驶到便宜站
                    {
                        float temp = curOil;
     
                        curOil = (s[j].dis - s[i].dis )/davg;//应保证油量
     
                        if (temp - curOil < 0)
                        {
                            res += (curOil - temp)*s[i].pri;//补充加油
                        }
                        else
                        {
                            curOil = temp;//不需要加油
                        }
                          
                        isCheap = true;
                        break;
                    }
                }// end of for
                //最大距离内未找到便宜站
                if (!isCheap)
                {
                    if (curPos+maxDis>=d)//到达终点
                    {
                        res += ((d - curPos)/davg - curOil) *s[i].pri;
                        cout << setiosflags(ios::fixed) << setprecision(2);
                        cout << res << endl;
     
                        break;
                    }
                    else//未到终点,加满油
                    {
                        res += (cmax - curOil)*s[i].pri;
                        curOil = cmax;
                    }
                }
            }//end of for (每次一站)
     
        }//end of while
        return 0;
    }


  • 相关阅读:
    javascript定义变量和优先级的问题
    css expression explaination
    apply()与call()详解
    jquery $(document).ready() 与window.onload的区别
    ES5严格模式
    css margin collapse
    作业 20181016-10 每周例行报告
    作业 20181009-9 每周例行报告
    作业 20180925-1 每周例行报告
    20180925-7 规格说明书-吉林市2日游
  • 原文地址:https://www.cnblogs.com/ymjia/p/3590301.html
Copyright © 2011-2022 走看看