zoukankan      html  css  js  c++  java
  • 1007 Maximum Subsequence Sum (25)(25 point(s))

    problem

    Given a sequence of K integers { N~1~, N~2~, ..., N~K~ }. A continuous subsequence is defined to be { N~i~, N~i+1~, ..., N~j~ } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
    
    Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
    
    Input Specification:
    
    Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.
    
    Output Specification:
    
    For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
    
    Sample Input:
    
    10
    -10 1 2 3 4 -5 -23 3 7 -21
    Sample Output:
    
    10 1 4
    

    tip

    求最大子序列和。

    anwser

    #include<bits/stdc++.h>
    using namespace std;
    
    #define Max 10001
    #define INF 0x3f3f3f3f
    
    int K, num[Max], neg = 0;
    
    int main(){
    //	freopen("test.txt", "r", stdin);
    	cin>>K;
    	for(int i = 0; i < K; i++){
    		cin>>num[i];
    		if(num[i] < 0) neg++;
    	}
    	
    	int sum = 0, firstIndex = 0, lastIndex = K-1, maxSum = 0, temp = 0;
    	for(int i = 0; i < K; i++){
    		sum += num[i];
    		if(maxSum < sum || (sum == 0 && lastIndex == K-1)) {
    			maxSum = sum;
    			temp = firstIndex;
    			lastIndex = i;
    		}
    		if(sum <= 0){
    			sum = 0;
    			firstIndex = i+1;
    		}
    	}
    	if(neg == K) {
    		temp = 0;
    		lastIndex = K-1;
    	}
    	cout<<maxSum<<" "<<num[temp]<<" "<<num[lastIndex];
    	return 0;
    }
    
    /*
    10
    -10 1 2 3 4 -5 -23 3 7 -21
    */
    

    experience

    • 数据有毒。
      • 所有数都为正的情况,以及0与负数的情况,有点冲突。
  • 相关阅读:
    R语言代写混合时间模型预测对时间序列进行点估计
    python代写安娜卡列妮娜词云图制作
    R语言代写markov switching model马尔可夫转换分析研究水资源
    R语言代写markov switching model马尔可夫转换模型研究商业周期
    Python代写数据可视化-seabornIris鸢尾花数据
    R语言代写聚类算法的应用实例
    用TensorFlow代写实现MNIST
    R语言代写Copula的贝叶斯非参数估计
    r语言代写预测波动率的实现:ARCH模型与HAR-RV模型
    CF932E Team Work 第二类斯特林数
  • 原文地址:https://www.cnblogs.com/yoyo-sincerely/p/9265663.html
Copyright © 2011-2022 走看看