zoukankan      html  css  js  c++  java
  • 1011 World Cup Betting (20)(20 point(s))

    problem

    With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.
    
    Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.
    
    For example, 3 games' odds are given as the following:
    
     W    T    L
    1.1  2.5  1.7
    1.2  3.0  1.6
    4.1  1.2  1.1
    To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).
    
    Input
    
    Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.
    
    Output
    
    For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.
    
    Sample Input
    
    1.1 2.5 1.7
    1.2 3.0 1.6
    4.1 1.2 1.1
    Sample Output
    
    T T W 37.98
    

    tip

    answer

    #include<bits/stdc++.h>
    using namespace std;
    
    #define INF 0x3f3f3f3f
    
    float GetMax(float a, float b, float c){
    	return max(max(a, b),c);
    }
    
    int GetStatus(float a, float b, float c){
    	if (a > b){
    		if( a > c) return 0;
    		else return 2;
    	}
    	if(a < b){
    		if( b > c) return 1;
    		else return 2;
    	}
    	return -1;
    }
    int main(){
    //	freopen("test.txt", "r", stdin);
    	float a, b, c, mul = 1;
    	for(int i = 0; i < 3; i++){
    		cin>>a>>b>>c;
    		mul *= GetMax(a, b, c);
    		switch(GetStatus(a, b, c)){
    			case 0: cout<<"W ";break;
    			case 1: cout<<"T ";break;
    			case 2: cout<<"L ";break;
    			default: return -1;
    		}
    	}
    	
    	cout<<fixed<<setprecision(2)<<(mul*0.65 - 1)*2;
    	return 0;
    }
    

    experience

    • 加快速度,这题目还要20分钟?
  • 相关阅读:
    边缘节点 如何判断CDN的预热任务是否执行完成刷新 路由追踪 近期最少使用算法
    查看恶意登录的尝试账号
    系统启动时发生了什么?
    JMS学习(五)--ActiveMQ中的消息的持久化和非持久化 以及 持久订阅者 和 非持久订阅者之间的区别与联系
    查找最近修改过的文件 并处理
    时间写入文件名 nohup 原理 Command In Background your shell may have its own version of nohup
    nohup COMMAND > FILE
    证明即程序、结论公式即程序类型
    C++学习注意
    C++标准库简介(转)
  • 原文地址:https://www.cnblogs.com/yoyo-sincerely/p/9296218.html
Copyright © 2011-2022 走看看