zoukankan      html  css  js  c++  java
  • 1036 Boys vs Girls (25)(25 point(s))

    problem

    This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.
    
    Input Specification:
    
    Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.
    
    Output Specification:
    
    For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade~F~-grade~M~. If one such kind of student is missing, output "Absent" in the corresponding line, and output "NA" in the third line instead.
    
    Sample Input 1:
    
    3
    Joe M Math990112 89
    Mike M CS991301 100
    Mary F EE990830 95
    Sample Output 1:
    
    Mary EE990830
    Joe Math990112
    6
    Sample Input 2:
    
    1
    Jean M AA980920 60
    Sample Output 2:
    
    Absent
    Jean AA980920
    NA
    

    tip

    answer

    #include<iostream>
    #include<vector>
    #include<algorithm>
    
    using namespace std;
    
    int N;
    struct P{
    	string name, gender;
    	int grade;
    };
    
    vector<P> lm, hf;
    
    bool Comp(P a, P b){
    	return a.grade < b.grade;
    }
    
    int main(){
    //	freopen("test.txt", "r", stdin);
    	cin>>N;
    	string name, sex, gender;
    	int grade;
    	for(int i = 0; i < N; i++)	{
    		cin>>name>>sex>>gender>>grade;
    		if(sex == "M"){
    			lm.push_back({name, gender, grade});
    		}else{
    			hf.push_back({name, gender, grade});
    		}
    	}
    	sort(lm.begin(), lm.end(), Comp);
    	sort(hf.begin(), hf.end(), Comp);
    	bool flag = true;
    	if(hf.size() == 0 || lm.size() == 0){
    		flag = false;
    	}
    	P woman, man;
    	if(hf.size()) {
    		woman = hf[hf.size()-1];
    		cout<<woman.name<<" "	<<woman.gender<<endl;
    	}
    	else cout<<"Absent"	<<endl;
    	
    	if(lm.size()) {
    		man   = lm[0];
    		cout<<man.name<<" "<<man.gender<<endl;
    	}
    	else cout<<"Absent"	<<endl;
    	
    	if(flag) cout<<woman.grade - man.grade<<endl;
    	else cout<<"NA"	<<endl;
    	return 0;
    }
    

    experience

  • 相关阅读:
    正则表达式在线测试(生成)工具
    org.eclipse.swt.custom.StyledText.getScrollbarsMode()I
    MySQL修改表一次添加多个列(字段)和索引
    How can I view currently running MySQL queries?( 查看正在运行的MySQL语句/脚本命令)
    faster alter table add column
    提取data.frame中的部分数据(不含列标题和行标题)
    How to generate a random number in R
    INSTALLMENT of QValue
    Linux 执行ll命令时指定按文件时间或大小排序
    替换 data.frame 中的特殊的值
  • 原文地址:https://www.cnblogs.com/yoyo-sincerely/p/9362655.html
Copyright © 2011-2022 走看看