zoukankan      html  css  js  c++  java
  • 算法思考: poj 1969 Count on Canton

                                      A - Count on Canton
    Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u
    Submit Status

    Description

    One of the famous proofs of modern mathematics is Georg Cantor's demonstration that the set of rational numbers is enumerable. The proof works by using an explicit enumeration of rational numbers as shown in the diagram below.
    1/1 1/2 1/3 1/4 1/5 ...
    
    2/1 2/2 2/3 2/4
    3/1 3/2 3/3
    4/1 4/2
    5/1

    In the above diagram, the first term is 1/1, the second term is 1/2, the third term is 2/1, the fourth term is 3/1, the fifth term is 2/2, and so on.

    Input

    The input list contains a single number per line and will be terminated by endof-file.

    Output

    You are to write a program that will read a list of numbers in the range from 1 to 10^7 and will print for each number the corresponding term in Cantor's enumeration as given below.

    Sample Input

    3
    14
    7

    Sample Output

    TERM 3 IS 2/1
    TERM 14 IS 2/4
    TERM 7 IS 1/4



    代码:
    #include <stdio.h>
    #include <string.h>

    int main()
    {
        int n;
        int i, j;
        int dd, ff;
        int d, c;

        while(scanf("%d", &n)!=EOF )
        {
            d = 1;
            while(( (1+d)*d)/2 < n)
            {
                d++;
            }
            c = d-1;
            if(d%2==1)//奇数列
            {
                dd = d-( n-(1+c)*c/2 )+1 ;
                ff = n-(1+c)*c/2;
            }
            else if(d%2==0)//偶数列
            {
                dd = n-(1+c)*c/2 ;
                ff = d-( n-(1+c)*c/2 ) +1;
            }
            printf("TERM %d IS %d/%d ", n, dd, ff );
        }
        return 0;
    }
  • 相关阅读:
    Codeforces Round #470 (rated, Div. 2, based on VK Cup 2018 Round 1)C. Producing Snow
    day69 Django--Form组件
    day68 Django--中间件
    day67 Cookie&Session
    day66 AJAX
    day62 Django框架--视图系统&路由系统
    day65 django--ORM3
    day63 django--ORM
    Day64 django--ORM2
    Day61 Django框架--模板语言2
  • 原文地址:https://www.cnblogs.com/yspworld/p/3874836.html
Copyright © 2011-2022 走看看