zoukankan      html  css  js  c++  java
  • poj 3259(bellman最短路径)

    Wormholes
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 30169   Accepted: 10914

    Description

    While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

    As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

    To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

    Input

    Line 1: A single integer, FF farm descriptions follow. 
    Line 1 of each farm: Three space-separated integers respectively: NM, and W 
    Lines 2..M+1 of each farm: Three space-separated numbers (SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
    Lines M+2..M+W+1 of each farm: Three space-separated numbers (SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

    Output

    Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

    Sample Input

    2
    3 3 1
    1 2 2
    1 3 4
    2 3 1
    3 1 3
    3 2 1
    1 2 3
    2 3 4
    3 1 8

    Sample Output

    NO
    YES

    Hint

    For farm 1, FJ cannot travel back in time. 
    For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

    Source

    USACO 2006 December Gold

    AC代码:

    #include<iostream>
    using namespace std;
    struct Point{
        int s,e,t;
    }a[10000];
    int se;
    int n,m,w;
    int bell_man(int start){
        int dis[10000];
        for(int i=1;i<=n;i++)
            dis[i]=999999;
        dis[start]=0;
    
        for(int i=1;i<n;i++)
        for(int j=0;j<se;j++)
            dis[a[j].e] = dis[a[j].e] > dis[a[j].s] + a[j].t ? dis[a[j].s] + a[j].t : dis[a[j].e];
    
        for(int i=0;i<se;i++){
            if(dis[a[i].e] > dis[a[i].s] + a[i].t)
                return 1;
        }
        return 0;
    }
    int main(){
        int T; cin>>T;
        while(T--){
            se=0;
            cin>>n>>m>>w;
            for(int i=0;i<m;i++){
                int s,e,t;
                cin>>s>>e>>t;
                a[se].s=s; a[se].e=e; a[se++].t=t;
                a[se].s=e; a[se].e=s; a[se++].t=t;
            }
            for(int i=0;i<w;i++){
                int s,e,t;
                cin>>s>>e>>t;
                a[se].s=s; a[se].e=e; a[se++].t=-t;
            }
            //int k;
            //for(k=1;k<=n;k++){          //事实上正确的起点应该要历遍全部点。可是这种超时了
                                         //这个题目仅仅要1点就能够了。算是题目的一个非常大漏洞吧,数据太水了
                if(bell_man(1)){
                    cout<<"YES"<<endl;
                    //break;
                }
            //}
            //if(k>n)
            else
                cout<<"NO"<<endl;
        }
        return 0;
    }
    


  • 相关阅读:
    ios中从相册:相机中获取图片信息
    ios中图片的绘画和截图
    UIPickView的简单介绍
    封装类的方式访问数据库(封装字符串、json)
    ajax用户名案例(重点)
    mysql中一对一,一对多,多对多关系
    会话控制:SESSION,COOKIE
    ajax简单案例:返回json型
    ajax同步,异步
    ajax简单案例:字符串返回类型
  • 原文地址:https://www.cnblogs.com/yxwkf/p/5032869.html
Copyright © 2011-2022 走看看