zoukankan      html  css  js  c++  java
  • HDU 1002 A + B Problem II(大整数相加)




    A + B Problem II
    Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

    Description

    I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B. 
     

    Input

    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000. 
     

    Output

    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases. 
     

    Sample Input

    2 1 2 112233445566778899 998877665544332211
     

    Sample Output

    Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
     

    题目大意:

    大整数相加。

    解题思路:

    先把短的补齐。从最后一位開始计算。不进为就直接放进容器,进为把取余的放进容器,然后前一位加一。


    代码:

    #include<iostream>
    #include<string>
    #include<cstdio>
    #include<vector>
    
    using namespace std;
    
    int t;
    string str1,str2;
    vector <char> v;
    
    void solve(){
        string temp;
        int a,l2;
        if(str1.length()<str2.length()){
            temp=str1;str1=str2;str2=temp;
            l2=str2.length();
        }
        for(int i=0;i<str1.length()-l2;i++){
            str2.insert(0,1,'0');
        }
        for(int i=0;i<str1.length();i++){
            a=str1[str1.length()-i-1]+str2[str2.length()-i-1]-2*'0';
            if(a>=10){
                v.push_back(a%10+'0');
                if(str1.length()-i-1==0){
                    v.push_back('1');break;
                }
                str1[str1.length()-i-2]=(char)(str1[str1.length()-i-2]+1);
            }
            else v.push_back((char)(a+'0'));
        }
         vector<char>::iterator it=v.end();
         it--;
         while(it!=v.begin()){
            if(*it=='0')
                v.erase(it);
            else break;
            it--;
         }
        for(int i=v.size()-1;i>=0;i--){
           cout<<v[i];
        }
        cout<<endl;
    }
    
    int main(){
        int casen=0;
        scanf("%d",&t);
        while(t-->0){
            cin>>str1>>str2;
            printf("Case %d:
    %s + %s = ",++casen,str1.c_str(),str2.c_str());
            v.clear();
            solve();
            if(t!=0)
                cout<<endl;
        }
        return 0;
    }
    



  • 相关阅读:
    show variables like "sql_mode"; set sql_mode=''; set sql_mode='NO_ENGINE_SUBSTITUTION,STRICT_TRANS_TABLES';
    c#单元测试
    React HookApi
    React Navigation验证流程
    React Native 错误笔记
    React Navigation 5.x BottomTab 使用
    React Navigation 5.x 使用
    虹软人脸识别SDK接入Milvus实现海量人脸快速检索
    iOS逆向:越狱手机抹除数据、还原,cydia出错(2021.04.21 完结)
    C#教程1:类型和变量
  • 原文地址:https://www.cnblogs.com/yxwkf/p/5203736.html
Copyright © 2011-2022 走看看