zoukankan      html  css  js  c++  java
  • HDU-1102-Constructing Roads(最小生成树)

    Problem Description
     
    There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

    We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
     
    Input
     
    The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

    Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
     
    Output
     
    You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 
     
    Sample Input
    3
    0 990 692
    990 0 179
    692 179 0
    1
    1 2
     
    Sample Output
    179

    思路:克鲁斯卡尔算法呗。已经连的就merge()先处理一下。
    坑点:
    1.题没说多组测试用例,但其实是多组...一般地(可能),输出一行就是多组,输出一个数是一组。
    2.剪枝的时候cnt初始值要注意一下,本题也可以不用剪枝。

    #include<cstdio>
    #include<algorithm>
    using namespace std;
    int N,Q;
    int pre[105];
    
    struct node{
        int a,b,len;    
    }l[5000];
    
    int find(int x){
        while(pre[x]!=x){
            int r=pre[x];
            pre[x]=pre[r];
            x=r;
        }
        return x;
    }
    
    void merge(int x,int y){
        int fx=find(x);
        int fy=find(y);
        if(fx!=fy) pre[fx]=fy;
    }
    
    int cmp(node x,node y){
        return x.len<y.len;
    }
    
    int main(){
        while(~scanf("%d",&N)){
        
            int cnt=0;
            int val;
            for(int i=1;i<=N;i++)
                pre[i]=i;
        
            for(int i=1;i<=N;i++){
                for(int j=1;j<=N;j++){
                    scanf("%d",&val);
                    if(j<=i) continue;
                
                    l[cnt].a=i;
                       l[cnt].b=j;
                    l[cnt].len=val;
                    cnt++;            
                }
            }
            sort(l,l+cnt,cmp);
            scanf("%d",&Q);
            cnt=0;
            for(int i=0;i<Q;i++){
                int a,b;
                scanf("%d%d",&a,&b); 
                if(find(a)!=find(b)) {//这个要注意一下,因为a,b可能已经有路,也有可能被别的城市间接连起来了。//为了后边剪枝 
                cnt++;  
                merge(a,b);
                }
            }
    int sum=0; for(int i=0;i<N*(N-1)/2;i++){ if(cnt==N-1) break;//这个剪枝可以不要,也能AC if(find(l[i].a)==find(l[i].b)) continue; sum+=l[i].len; merge(l[i].a,l[i].b); cnt++; } printf("%d ",sum); } return 0; }
  • 相关阅读:
    Python 解LeetCode:Intersection of Two Arrays
    flask中使用xlsxwriter导出excel文件
    python的xlwt模块的常用方法
    线程池理解
    内存屏障理解
    中断上半部,下半部理解
    DPDK l2fwd源码学习
    如何用perf工具
    如何迅速分析出系统CPU的瓶颈在哪里?
    怎么理解Linux软中断?
  • 原文地址:https://www.cnblogs.com/yzhhh/p/9954133.html
Copyright © 2011-2022 走看看