zoukankan      html  css  js  c++  java
  • POJ

    Feel Good

    Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people's memories about some period of life. 

    A new idea Bill has recently developed assigns a non-negative integer value to each day of human life. 

    Bill calls this value the emotional value of the day. The greater the emotional value is, the better the daywas. Bill suggests that the value of some period of human life is proportional to the sum of the emotional values of the days in the given period, multiplied by the smallest emotional value of the day in it. This schema reflects that good on average period can be greatly spoiled by one very bad day. 

    Now Bill is planning to investigate his own life and find the period of his life that had the greatest value. Help him to do so.

    Input

    The first line of the input contains n - the number of days of Bill's life he is planning to investigate(1 <= n <= 100 000). The rest of the file contains n integer numbers a1, a2, ... an ranging from 0 to 10 6 - the emotional values of the days. Numbers are separated by spaces and/or line breaks.

    Output

    Print the greatest value of some period of Bill's life in the first line. And on the second line print two numbers l and r such that the period from l-th to r-th day of Bill's life(inclusive) has the greatest possible value. If there are multiple periods with the greatest possible value,then print any one of them.

    Sample Input

    6
    3 1 6 4 5 2
    

    Sample Output

    60
    3 5


    单调递增栈,遍历最小值,找左右两端点,前缀和求出区间和×最小值,更新最大解。

    #include<stdio.h>
    #include<string.h>
    #include<stack>
    using namespace std;
    int main()
    {
        int n,i;
        long long max;
        long long a[100005],b[100005],l[100005],r[100005];
        stack<int> s;
        scanf("%d",&n);
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(l,0,sizeof(l));
        memset(r,0,sizeof(r));
        for(i=1;i<=n;i++){
            scanf("%lld",&a[i]);
            b[i]+=b[i-1]+a[i];
        }
        for(i=1;i<=n;i++){
            while(s.size()&&a[s.top()]>=a[i]) s.pop();
            l[i]=s.size()==0?1:(s.top()+1);
            s.push(i);
        }
        while(s.size()) s.pop();
        for(i=n;i>=1;i--){
            while(s.size()&&a[s.top()]>=a[i]) s.pop();
            r[i]=s.size()==0?n:(s.top()-1);
            s.push(i);
        }
        max=0;
        int ll=1,rr=1;
        for(i=1;i<=n;i++){
            if((b[r[i]]-b[l[i]-1])*a[i]>max){
                max=(b[r[i]]-b[l[i]-1])*a[i];
                ll=l[i];
                rr=r[i];
            }
        }
        printf("%lld
    %d %d
    ",max,ll,rr);
        return 0;
    }
  • 相关阅读:
    又快又准的sql瓶颈诊断方法
    Qps从300到1500的优化过程
    Mysql性能优化全揭秘-庖丁解牛
    java学习笔记16-抽象类
    java学习笔记15-封装
    java学习笔记14-多态
    java学习笔记13-重写与重载
    Git学习笔记08-远程仓库
    Python3+Appium学习笔记09-元素定位android_uiautomator
    Python3+Appium学习笔记08-元素定位
  • 原文地址:https://www.cnblogs.com/yzm10/p/7224337.html
Copyright © 2011-2022 走看看