zoukankan      html  css  js  c++  java
  • John 尼姆博弈

    John

    Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box. 

    Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game. 

    InputThe first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color. 

    Constraints: 
    1 <= T <= 474, 
    1 <= N <= 47, 
    1 <= Ai <= 4747 

    OutputOutput T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case. 

    Sample Input

    2
    3
    3 5 1
    1
    1

    Sample Output

    John
    Brother

    对于N堆的糖,一种情况下是每堆都是1,那么谁输谁赢看堆数就知道;
    对于不都是1的话,若这些堆是奇异局势,或说他们是非奇异局势,但非奇异局势皆可以转换到奇异局势。
    
    经典的尼姆问题是谁哪拿到最后一个则谁赢,本题是拿最后一个的输。
    下面分析第二种情况:
    1.初始给的是奇异局势的话,则先取者拿到最后一个为输。
    2.初始给的是非奇异局势的话,则先取者为赢。
    	对于任何奇异局势(a,b,c),都有a^b^c=0(^是代表异或).
    非奇异局势(a,b,c)(a<b<c)转换为奇异局势,只需将c变成a^b,即从c中减去c-(a^b)即可

    import java.util.*;
    
    public class Main {
        
        static Scanner sc = new Scanner(System.in);
        
        public static void main(String[] args){
            
            int t, n, x, f, ans, i;
            t = sc.nextInt();
            while((t--) != 0){
                n = sc.nextInt();
                ans = 0; f = 0;
                for(i = 1; i <= n; i++){
                    x = sc.nextInt();
                    ans ^= x;
                    if(x > 1) f = 1;
                }
                if(f == 0){
                    if((n & 1) != 0) System.out.println("Brother");
                    else System.out.println("John");
                }
                else{
                    if(ans == 0) System.out.println("Brother");
                    else System.out.println("John");
                }
            }
        }
    }
  • 相关阅读:
    cygwin配合NDK开发Android程序
    和菜鸟一起学c之函数指针
    和菜鸟一起学android4.0.3源码之SD卡U盘等自动挂载配置
    Android系统的开机画面显示过程分析
    android编译系统的makefile文件Android.mk写法
    Linux下makefile教程
    和菜鸟一起学linux之本地git中心仓库建立
    强人总结的Windows XP实用技巧45条(一)
    Webshell下自动挂马的ASP
    多进程Telnet的木马例子
  • 原文地址:https://www.cnblogs.com/yzm10/p/7525717.html
Copyright © 2011-2022 走看看