zoukankan      html  css  js  c++  java
  • 动态规划dp——天平1

    题目:http://poj.org/problem?id=1837

    Balance
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 16411   Accepted: 10310

    Description

    Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance.
    It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.
    Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.

    Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.
    It is guaranteed that will exist at least one solution for each test case at the evaluation.

    Input

    The input has the following structure:
    • the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);
    • the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm);
    • on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values.

    Output

    The output contains the number M representing the number of possibilities to poise the balance.

    Sample Input

    2 4	
    -2 3 
    3 4 5 8
    

    Sample Output

    2


    题目意思是给你一盏天平,天平左右两边的不同位置有钩子,给定一定数量的砝码,将所有砝码挂在天平上,问有多少种挂法?
    本题用动态规划,分析
        首先:定义一个数组dp[i][j] : 表示用前i个砝码,挂在天平上,使得天平达到状态j(状态j是指:j<0 天平左边比右边的重j克;j>0 天平右边比左边重j克;) 的挂法总数;
           weight[i]:表示第i个砝码的重量;
           dis[k] :表示第k个钩子的位置;
           hook:表示钩子的数量
            
        其次:根据题目意思可知,在极端情况,给定20个砝码, 每个均为25克,在天平左边 15 厘米 处 有钩子,将所有砝码放在天平最左边15厘米处,此时 j= - 20*25*15=7500 ,
           由于j作为数组下标不能是负数,所以我们可以在编写代码时将j右移7500个单位,平衡点j=0变为j=7500
        
        所以:其状态转移方程为
            dp[i][j] += dp[i-1][j-weight[i]*dis[k] ] 其中 k=1...hook;
    代码实现
       
    #include<iostream>
    #include<cstring>
    using namespace std;
    int main(){
    	int G,C;
    	int hook[25];
    	while(cin>>C>>G){
    		for(int i=1;i<=C;i++){
    			scanf("%d",&hook[i]);
    		}
    		int a[21][15005];
    		memset(a,0,sizeof(a));
    		int we1;
    		scanf("%d",&we1);
    		for(int i=1;i<=C;i++){
    			a[1][7500+hook[i]*we1]=1;
    		}
    	//	cout<<a[1][7494]<<" "<<a[1][7509]<<endl;
    		for(int i=2;i<=G;i++){
    			int x;
    			scanf("%d",&x);
    			
    			for(int j=1;j<=15000;j++){
    				for(int k=1;k<=C;k++){
    					if(j-x*hook[k]>0&&j-x*hook[k]<=15000){
    						a[i][j]+=a[i-1][j-x*hook[k]]; 		
    					//	if(a[i][j]) cout<<a[i][j]<<" "<<j-x*hook[k]<<" "<<i<<" "<<j<<endl;
    					}		
    				}
    			}
    			
    		}
    	//	for(int i=1;i<=20;i++)
    		cout<<a[G][7500]<<" "<<endl;
    	}			
    }
    

      

         
            
  • 相关阅读:
    koa2 中间件里面的next到底是什么
    nodejs 之 nvm和pm2
    javascript瀑布流
    转使用chrome命令行:disable
    MariaDB 用户与授权
    MariaDB TRANSACTION
    IHS .kdb转crt,key
    MariaDB TRIGGER
    MariaDB CURSOR
    MariaDB PROCEDURE
  • 原文地址:https://www.cnblogs.com/z-bear/p/9466407.html
Copyright © 2011-2022 走看看