zoukankan      html  css  js  c++  java
  • 杭电2577 多数组dp问题

    Problem Description
    Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
     
    Input
    The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
     
    Output
    For each test case, you must output the smallest times of typing the key to finish typing this string.
     
    Sample Input
    3 Pirates HDUacm HDUACM
     
    Sample Output
    8 8 8
    由于这里有大写锁定开关两种状态 所以需要两个数组a b来进行dp
    动态规划的问题实际上就是对多个子问题的优化处理问题 在考虑优化时 应该从一个子问题到下一个子问题的过程中找出所有可能的情况 并进行优化
     
    #include<stdio.h>
    #include<iostream>
    #include<string.h>
    int min(int x,int y)
    {
     if(x>y) return y;
     else return x;
    }
    int f(char x)//1为大写
    {
     if(x>='A'&&x<='Z') return 1;
     else return 0;
    }
    using namespace std;
    int main()
    {
        char s[130];
     int n,len,i,j,a[130];//开
     int b[130],t,mine;//关 a,b需要保证 其状态的变化量
     scanf("%d",&n);
     while(n--)
     {
      memset(a,0,sizeof(a));
      memset(b,0,sizeof(b));
      cin>>s;
      a[0]=1;
      len=strlen(s);
      for(i=0;i<len;i++)
      {
        if(f(s[i])==1)//da
        {
              a[i+1]=min(a[i]+1,b[i]+2);//开灯的话直接输入 关灯的话开灯在输入
        b[i+1]=min(a[i]+2,b[i]+2);// 开灯的话先输入再关 关灯的话按shitf在输入(这里可以开灯输入在关灯 但由于是找最少的次数 所以忽略)     
        } 
        else//xiao
        {
         a[i+1]=min(a[i]+2,b[i]+2);//开灯的话 按SHIFT输入 关灯的话 先输入在开灯(保证a数组的开灯状态)
         b[i+1]=min(a[i]+2,b[i]+1);//开灯的话  关灯再输入   关灯的话 直接输入
        }
      }
      a[len]++;// 最后不要忘了关灯
      mine=min(a[len],b[len]);
      cout<<mine<<endl;
     }
     return 0;
    }




     
  • 相关阅读:
    剑指 Offer 67. 把字符串转换成整数 && Leetcode 8 字符串转换整数 (atoi)
    剑指 Offer 49. 丑数 && Leetcode 264. 丑数 II
    [LeetCode] Implement strStr()
    [LeetCode] Rotate Image
    [LeetCode] Remove Duplicates from Sorted List II
    [LeetCode] Gas Station
    OpenCV-paper detection & perspective transformation 相关资料
    Install PIL on mac osX10.9
    为什么是 n(n+1)/2 ?
    数组排序
  • 原文地址:https://www.cnblogs.com/z1141000271/p/5363726.html
Copyright © 2011-2022 走看看