zoukankan      html  css  js  c++  java
  • poj 2955 Brackets

    Description

    We give the following inductive definition of a “regular brackets” sequence:

    • the empty sequence is a regular brackets sequence,
    • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
    • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
    • no other sequence is a regular brackets sequence

    For instance, all of the following character sequences are regular brackets sequences:

    (), [], (()), ()[], ()[()]

    while the following character sequences are not:

    (, ], )(, ([)], ([(]

    Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

    Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

    Input

    The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

    Output

    For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

    Sample Input

    ((()))
    ()()()
    ([]])
    )[)(
    ([][][)
    end

    Sample Output

    6
    6
    4
    0
    6
    题意:求括号匹配的最大数量
    区间dp模板题吧。。 今天复习一下 状态转移看代码
    ac代码:
    #include <cstdio>
    #include <cstring>
    #include <iostream>
    #include <queue>
    #include <stack>
    #include <string>
    #define mt(a) memset(a,0,sizeof(a))
    using namespace std;
    int dp[105][105];
    int main()
    {
        string s;
        while(cin>>s)
        {
            if(s=="end") break;
            mt(dp);
            int len=s.size();
            for(int l=2;l<=len;l++)
            {
                for(int i=0;i+l-1<len;i++)
                {
                    int j=i+l-1;
                    for(int k=i;k<j;k++)
                    {
                        if((s[k]=='(' && s[j]==')') || (s[k]=='[' && s[j]==']'))
                        {
                            dp[i][j]=max(dp[i][j],dp[i][k]+dp[k+1][j-1]+2);// 区间dp的状态转移是典型的用小区间去推出大区间 我们这里枚举每个长度内可以匹配的最大值
                        }
                        else dp[i][j]=max(dp[i][j],max(dp[i][k],dp[k][j]));// 匹配不了就找出子区间的最大值
                    }
                }
            }
            cout<<dp[0][len-1]<<endl;
        }
        return 0;
    }
  • 相关阅读:
    python基础之包、模块、命名空间和作用域
    python基础之函数式编程
    python基础之文件操作
    python基础之psutil模块和发邮件(smtplib和yagmail)
    【面试题21】包含min函数的栈
    【面试题20】顺时针打印矩阵
    【面试题19】二叉树的镜像
    【面试题18】树的子结构
    【面试题17】合并两个排序的链表
    【面试题16】反转链表
  • 原文地址:https://www.cnblogs.com/z1141000271/p/7447419.html
Copyright © 2011-2022 走看看