zoukankan      html  css  js  c++  java
  • poj3630 Phone List

    Phone List
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 31545   Accepted: 9244

    Description

    Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

    • Emergency 911
    • Alice 97 625 999
    • Bob 91 12 54 26

    In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

    Input

    The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

    Output

    For each test case, output "YES" if the list is consistent, or "NO" otherwise.

    Sample Input

    2
    3
    911
    97625999
    91125426
    5
    113
    12340
    123440
    12345
    98346

    Sample Output

    NO
    YES

    Source

    大致题意:给定n个字符串,问有没有两个字符串使得一个是另一个的前缀.
    分析:Trie模板题,需要判断的情况有自己是不是其它串的前缀,有没有其它串是自己的前缀,对于第一个判断,如果在插入的过程中没有新建任何节点,就是其它串的前缀,对于第二个判断,如果中途遇到了结尾标记,就是的.
    #include <cstdio>
    #include <cstring>
    #include <iostream>
    #include <algorithm>
    
    using namespace std;
    
    const int maxn = 1e5 + 5;
    
    int T, n, len, tot, ans;
    char s[1000010];
    
    struct node
    {
        int tr[30];
        bool end;
        void clear() {
            memset(tr, 0, sizeof(tr));
            end = false;
        }
    }e[100010];
    
    bool insert(char *ss)
    {
        bool flagg = false;
        int u = 1, len = strlen(ss);
        for (int i = 0; i < len; i++)
        {
            if (!e[u].tr[ss[i] - '0'])
                e[u].tr[ss[i] - '0'] = ++tot;
            else
                if (i == len - 1)
                    flagg = 1;
            if (e[u].end)
                flagg = 1;
            u = e[u].tr[ss[i] - '0'];
        }
        e[u].end = 1;
        return flagg;
    }
    
    int main()
    {
        scanf("%d", &T);
        while (T--)
        {
            scanf("%d", &n);
            for (int i = 1; i <= tot; i++)
                e[i].clear();
            tot = 1;
            ans = 0;
            for (int i = 1; i <= n; i++)
            {
                scanf("%s", s);
                if (insert(s))
                    ans = 1;
            }
            if (!ans)
                puts("YES");
            else
                puts("NO");
        }
    
        return 0;
    }
  • 相关阅读:
    POJ 3669 Meteor Shower(bfs)
    MongoDB 分片的原理、搭建、应用
    Linux下Mongodb安装和启动配置
    目录操作
    一阶段第四次整理(关于滚动条监听的进一步解释)
    HTML DOM 节点介绍(nodeName,nodeValue,nodeType)
    ASP.NET 开发人员应该知道的8个网站
    Java 里快如闪电的线程间通讯
    php-多态
    Winform控件学习-TreeView
  • 原文地址:https://www.cnblogs.com/zbtrs/p/8047078.html
Copyright © 2011-2022 走看看