zoukankan      html  css  js  c++  java
  • nyoj-素数求和问题

    /*素数求和问题
    时间限制:3000 ms | 内存限制:65535 KB
    难度:2
    描述
    现在给你N个数(0<N<1000),现在要求你写出一个程序,找出这N个数中的所有素数,并求和。
    输入
    第一行给出整数M(0<M<10)代表多少组测试数据
    每组测试数据第一行给你N,代表该组测试数据的数量。
    接下来的N个数为要测试的数据,每个数小于1000
    输出
    每组测试数据结果占一行,输出给出的测试数据的所有素数和
    样例输入
    3
    5
    1 2 3 4 5
    8
    11 12 13 14 15 16 17 18
    10
    21 22 23 24 25 26 27 28 29 30
    样例输出
    10
    41
    52
    */
    #include<stdio.h>
    int a[1000]={1,1,0,0,0};
    void f()
    {
    int i,j;
    for(i=2;i<100;i++)
    {
    if(a[i]==0)
    for(j=i*i;j<=1000;j+=i)
    a[j]=1;
    }
    }
    int main()
    {
    int m;
    f();
    scanf("%d",&m);
    while(m--)
    {
    int b,c,d,sum=0;
    scanf("%d",&b);
    for(c=1;c<=b;c++)
    {
    scanf("%d",&d);
    if( a[d]==0)
    sum=sum+d;}
    printf("%d ",sum);
    }
    return 0;
    }

  • 相关阅读:
    Django系列:TemplateView,ListView,DetailView
    Django系列:开发自己的RestAPI
    Django系列:Restful CBV
    Django系列:RestFul
    Django系列12:Django模型关系
    B
    All about that base
    Safe Passage
    A
    Isomorphic Inversion
  • 原文地址:https://www.cnblogs.com/zcl512/p/3705669.html
Copyright © 2011-2022 走看看