zoukankan      html  css  js  c++  java
  • 字符串的应用

    Binary String Matching

    时间限制:3000 ms  |  内存限制:65535 KB
    难度:3
     
    描述
    Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit
     
    输入
    The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.
    输出
    For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
    样例输入
    3
    11
    1001110110
    101
    110010010010001
    1010
    110100010101011 
    样例输出
    3
    0
    3 


    #include<iostream>
    #include<stack>
    #include<string>
    #include<vector>
    using namespace std;
    void main()
    {
    int n,i=0,k=0,t;
    cout<<"请输入比较次数"<<endl;
    cin>>n;
    while(n--)
    {
    string s,s1;
    cout<<"请输入字符串"<<endl;
    cin>>s;
    //cout<<s<<endl;
    cout<<"请输入子串"<<endl;
    cin>>s1;
    //cout<<s1<<endl;;
    while(s.find(s1,i)!=string::npos)
    {
    t=s.find(s1,i);
    //cout<<"位置为 "<<t<<endl;
    i=t+1;
    k++;
    }
    cout<<k<<endl;
    k=0;
    i=0;
    }
    }



  • 相关阅读:
    ajaxfileupload.js类实现异步文件上传
    设计模式代理
    状态码的分析
    图片的格式的分析、 图片优化
    BFC
    css3 的新属性
    二列布局、三列布局总结
    position的定义
    new Vue 发生了什么
    数据驱动
  • 原文地址:https://www.cnblogs.com/zdblog/p/3631368.html
Copyright © 2011-2022 走看看