zoukankan      html  css  js  c++  java
  • CD(01背包)

    You have a long drive by car ahead. You have a tape recorder, but unfortunately your best music is on CDs. You need to have it on tapes so the problem to solve is: you have a tape N minutes long. How to choose tracks from CD to get most out of tape space and have as short unused space as possible.

    Assumptions:

    • number of tracks on the CD. does not exceed 20
    • no track is longer than N minutes
    • tracks do not repeat
    • length of each track is expressed as an integer number
    • N is also integer

    Program should find the set of tracks which fills the tape best and print it in the same sequence as the tracks are stored on the CD

    Input

    Any number of lines. Each one contains value N, (after space) number of tracks and durations of the tracks. For example from first line in sample data: N=5, number of tracks=3, first track lasts for 1 minute, second one 3 minutes, next one 4 minutes

     Output

    Set of tracks (and durations) which are the correct solutions and string ``sum:" and sum of duration times.

     Sample Input

     5 3 1 3 4

    10 4 9 8 4 2

    20 4 10 5 7 4

    90 8 10 23 1 2 3 4 5 7

    45 8 4 10 44 43 12 9 8 2

     Sample Output

    1 4 sum:5
    8 2 sum:10
    10 5 4 sum:19
    10 23 1 2 3 4 5 7 sum:55
    4 10 12 9 8 2 sum:45
    题目大意:
    给定n,m,然后给m个数字,组成尽可能接近n的和,以及组成部分具体数字
    解题思路:
    01背包模板,需要进行记录路径.
    #include <bits/stdc++.h>
    using namespace std;
    const int N=1e4+5;
    int dp[N],val[25];
    int vis[25][N];///记录路径
    int main()
    {
        int n,m;
        while(cin>>n>>m)
        {
            memset(dp,0,sizeof dp);
            memset(vis,0,sizeof vis);
            for(int i=0;i<m;i++)
                cin>>val[i];
            for(int i=0;i<m;i++)
            {
                for(int j=n;j>=val[i];j--)
                {
                    if(dp[j]<=dp[j-val[i]]+val[i])
                        dp[j]=dp[j-val[i]]+val[i],vis[i][j]=1;
                }
            }
            int j=n;
            for(int i=m-1;i>=0;i--)///从后往前的线路是唯一的
            {
                if(vis[i][j])
                    cout<<val[i]<<' ',j-=val[i];
            }
            cout<<"sum:"<<dp[n]<<'
    ';
        }
    }
  • 相关阅读:
    玩聚网和百度新闻的技术差异性
    拿下“[warn] (OS 64)指定的网络名不再可用”错误
    转型要回答的四个问题和一根筋变形Push法
    奇虎之奇酷改版为热点memeTracker之分析
    新媒体的运营之道【三】
    疑似BUG:Python SGMLParser处理html中的javascript失当
    智能语义参透股票 小公司不见得比输大公司
    新SNS的创立和运营之道[360圈座谈]
    在路上:语义和创业
    论Push!
  • 原文地址:https://www.cnblogs.com/zdragon1104/p/8990179.html
Copyright © 2011-2022 走看看