zoukankan      html  css  js  c++  java
  • Brackets(区间DP)

    We give the following inductive definition of a “regular brackets” sequence:

    • the empty sequence is a regular brackets sequence,
    • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
    • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
    • no other sequence is a regular brackets sequence

    For instance, all of the following character sequences are regular brackets sequences:

    (), [], (()), ()[], ()[()]

    while the following character sequences are not:

    (, ], )(, ([)], ([(]

    Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

    Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

    Input

    The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

    Output

    For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

    Sample Input

    ((()))
    ()()()
    ([]])
    )[)(
    ([][][)
    end

    Sample Output

    6
    6
    4
    0
    6
    题目大意:
    给定一个字符串,求最长合法子序列的长度。合法子序列就是每对括号一一匹配,如(), [], (()), ()[], ()[()]等等。
    这题可以逆向想,求需要加多少括号使它合法,然后总长度减去它就行了。
    #include <iostream>
    #include <string>
    #include <cstring>
    using namespace std;
    int dp[205][205];
    int main()
    {
        ios::sync_with_stdio(false);
        string s;
        while(cin>>s)
        {
            if(s=="end") break;
            memset(dp,0,sizeof dp);
            int n=s.size();
            for(int i=0;i<n;i++)
                dp[i][i]=1;
            for(int l=1;l<n;l++)
                for(int i=0;i<n;i++)
                {
                    int j=i+l;
                    dp[i][j]=1<<30;
                    if(s[i]=='('&&s[j]==')'||s[i]=='['&&s[j]==']')
                        dp[i][j]=dp[i+1][j-1];
                    for(int k=i;k<j;k++)
                        dp[i][j]=min(dp[i][j],dp[i][k]+dp[k+1][j]);
                }
            cout<<n-dp[0][n-1]<<'
    ';
        }
        return 0;
    }
     
  • 相关阅读:
    SSM框架使用遇到的问题
    《深入浅出wpf》第四章 x名称空间详解
    《深入浅出wpf》第三章
    《深入浅出wpf》第二章
    《深入浅出wpf》第一章
    《深入浅出wpf》序
    opencv2411配置
    k均值
    qt新建类报无法解析外部符号(link错误)
    fatal error LNK1123: 转换到 COFF 期间失败: 文件无效或损坏
  • 原文地址:https://www.cnblogs.com/zdragon1104/p/9171425.html
Copyright © 2011-2022 走看看