zoukankan      html  css  js  c++  java
  • Investment(完全背包)

    John never knew he had a grand-uncle, until he received the notary's letter. He learned that his late grand-uncle had gathered a lot of money, somewhere in South-America, and that John was the only inheritor. 
    John did not need that much money for the moment. But he realized that it would be a good idea to store this capital in a safe place, and have it grow until he decided to retire. The bank convinced him that a certain kind of bond was interesting for him. 
    This kind of bond has a fixed value, and gives a fixed amount of yearly interest, payed to the owner at the end of each year. The bond has no fixed term. Bonds are available in different sizes. The larger ones usually give a better interest. Soon John realized that the optimal set of bonds to buy was not trivial to figure out. Moreover, after a few years his capital would have grown, and the schedule had to be re-evaluated. 
    Assume the following bonds are available: 
    Value Annual
    interest
    4000
    3000
    400
    250

    With a capital of e10 000 one could buy two bonds of $4 000, giving a yearly interest of $800. Buying two bonds of $3 000, and one of $4 000 is a better idea, as it gives a yearly interest of $900. After two years the capital has grown to $11 800, and it makes sense to sell a $3 000 one and buy a $4 000 one, so the annual interest grows to $1 050. This is where this story grows unlikely: the bank does not charge for buying and selling bonds. Next year the total sum is $12 850, which allows for three times $4 000, giving a yearly interest of $1 200. 
    Here is your problem: given an amount to begin with, a number of years, and a set of bonds with their values and interests, find out how big the amount may grow in the given period, using the best schedule for buying and selling bonds.

    Input

    The first line contains a single positive integer N which is the number of test cases. The test cases follow. 
    The first line of a test case contains two positive integers: the amount to start with (at most $1 000 000), and the number of years the capital may grow (at most 40). 
    The following line contains a single number: the number d (1 <= d <= 10) of available bonds. 
    The next d lines each contain the description of a bond. The description of a bond consists of two positive integers: the value of the bond, and the yearly interest for that bond. The value of a bond is always a multiple of $1 000. The interest of a bond is never more than 10% of its value.

    Output

    For each test case, output – on a separate line – the capital at the end of the period, after an optimal schedule of buying and selling.

    Sample Input

    1
    10000 4
    2
    4000 400
    3000 250

    Sample Output

    14050
    题目大意:
    输入x,y,n,分别代表本金,年数,n个地方,接下来n对数字分别代表需要的钱,和产生的利息。
    由于本金和需要的钱都是1000的倍数,可以将它们都除以1000,可以省内存,也可以省时间。
    #include <iostream>
    #include <cstring>
    using namespace std;
    int dp[50000],v[10],w[10];
    int main()
    {
        ios::sync_with_stdio(false);
        int T,x,y,n;
        cin>>T;
        while(T--)
        {
            cin>>x>>y>>n;
            for(int i=1;i<=n;i++)
                cin>>v[i]>>w[i],v[i]/=1000;
            for(int k=1;k<=y;k++)
            {
                int s=x/1000;///本金时刻变化的
                memset(dp,0,sizeof dp);
                for(int i=1;i<=n;i++)
                    for(int j=v[i];j<=s;j++)
                        dp[j]=max(dp[j],dp[j-v[i]]+w[i]);
                x+=dp[s];///本金更新
            }
            cout<<x<<'
    ';
        }
        return 0;
    }
    
    
    
     
  • 相关阅读:
    fatal: unable to access ‘https://github.com/Homebrew/brew/‘: Error in the HTTP2 framing layer
    leetcode题目两数和、最大字符串长度、中位数、最长回文子串
    zabbix5.x版本添加自定义监控+263邮件报警
    php过滤特殊字符方法
    js中e相关位置
    少有人走的路-心智成熟的旅程-斯科特·派克
    ios脱壳
    docker 容器开机自启
    Java8 Stream的使用
    Entity Frameworker 的核心 EDM(Entity Data Model)模式
  • 原文地址:https://www.cnblogs.com/zdragon1104/p/9189034.html
Copyright © 2011-2022 走看看