zoukankan      html  css  js  c++  java
  • hdu 1040

    As Easy As A+B

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 70286    Accepted Submission(s): 29895


    Problem Description
    These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
    Give you some integers, your task is to sort these number ascending (升序).
    You should know how easy the problem is now!
    Good luck!
     
    Input
    Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line. 
    It is guarantied that all integers are in the range of 32-int.
     
    Output
    For each case, print the sorting result, and one line one case.
     
    Sample Input
    2 3 2 1 3 9 1 4 7 2 5 8 3 6 9
     
    Sample Output
    1 2 3 1 2 3 4 5 6 7 8 9
     
    Author
    lcy
    思路:手写快排,
    #include<cstdio>
    #include<set>
    #include<iostream>
    #include<functional>
    #include<algorithm>
    using namespace std;
    void quick_sort(int a[], int low, int high)
    {
        if (low >= high)return;
        int s = low, e = high, key = a[low];
        while (s < e){
            while (s < e && a[e] >= key)e--;
            a[s] = a[e];
            while (s < e && a[s] <= key)s++;
            a[e] = a[s];
        }
        a[s] = key;
        quick_sort(a, low, s - 1);
        quick_sort(a, s + 1, high);
    }
    int main()
    {
        int a[1006];
        int t; cin >> t;
        while (t--) {
            int n; cin >> n;
    
            for (int i = 0; i < n; i++)
                cin >> a[i];
            quick_sort(a, 0, n - 1);
            for (int i = 0; i < n; i++){
                if (i == n - 1)cout << a[i] << endl;
                else cout << a[i] << " ";
            }
    
        }
        return 0;
    }
  • 相关阅读:
    EMV内核使用中的常见问题
    SM2国密证书合法性验证
    WP8.1中C++的winodws运行时组件位移操作的差异
    [源码]Literacy 快速反射读写对象属性,字段
    Vue 单文件元件 — vTabs
    vue-router路径计算问题
    前端跨域新方案尝试
    Vue 单文件原件 — vCheckBox
    JavaScript 功能类 Url.js
    Vue 学习笔记 — 组件初始化
  • 原文地址:https://www.cnblogs.com/zengguoqiang/p/8819891.html
Copyright © 2011-2022 走看看