zoukankan      html  css  js  c++  java
  • POJ1860——Bellman_ford——Currency Exchange

    Description

    Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
    For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
    You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively. 
    Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

    Input

    The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103
    For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102
    Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104

    Output

    If Nick can increase his wealth, output YES, in other case output NO to the output file.

    Sample Input

    3 2 1 20.0
    1 2 1.00 1.00 1.00 1.00
    2 3 1.10 1.00 1.10 1.00
    

    Sample Output

    YES

    Source

    Northeastern Europe 2001, Northern Subregion
    大意:有N种货币,M个货币所,即交易M次,手中为s货币,共V数量,接下来是交换的两种货币出与进的rate和cost,要求是否能满足进行一定步骤后能盈利,即以s货币为单位的数目变多,用最短路径思想,bellman_ford(贝尔曼夫德)
    #include<stdio.h>
    struct edge
    {
        int u , v ;
        double r , c ;
    }e[300];
    int n , m , s ;
    double cap ;
    int cnt = 0 ;
    double d[300] ;
    
    bool Bellman_ford()
    {
        for (int i = 1 ; i <= n ; i++)
            d[i] = 0 ;
        d[s] = cap ;
        bool flag ;
        for (int i = 1 ; i <= n ; i++) {//单纯循环
            flag = 1 ;
            for (int j = 0 ; j < cnt ; j++) {
                if (d[e[j].v] < ( d[e[j].u] - e[j].c ) * e[j].r ) {
                    flag = 0 ;
                    d[e[j].v] = ( d[e[j].u] - e[j].c ) * e[j].r ;
                }
            }
            if (flag)
                return false ;
        }
    
        return true ;
    }
    
    int main ()
    {
        scanf ("%d%d%d%lf" , &n , &m , &s , &cap) ;
        while (m--) {
            scanf ("%d%d%lf%lf" , &e[cnt].u , &e[cnt].v , &e[cnt].r , &e[cnt].c) ;
            cnt++;
            e[cnt].u = e[cnt - 1].v , e[cnt].v = e[cnt - 1].u ;
            scanf ("%lf%lf" , &e[cnt].r , &e[cnt].c) ;
            cnt++;
        }
        if (Bellman_ford())
            puts ("YES") ;
        else
            puts ("NO") ;
    
        return 0 ;
    }
    View Code

    里面if的判定是为了去除负向回路,bellman_ford主要是个函数,将数据在这个函数里运行,如果成立返回true.

  • 相关阅读:
    Live2D 看板娘
    Live2D 看板娘
    Live2D 看板娘
    Live2D 看板娘
    Live2D 看板娘
    Live2D 看板娘
    Live2D 看板娘
    Live2D 看板娘
    Bound mismatch: The typae CertificateDirectory is not a valid substitute for the bounded parameter <M extends Serializable>
    Duplicate property mapping of contactPhone found in
  • 原文地址:https://www.cnblogs.com/zero-begin/p/4316615.html
Copyright © 2011-2022 走看看