zoukankan      html  css  js  c++  java
  • POJ1159——LCS+滚动数组——Palindrome

    Description

    A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

    As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

    Input

    Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

    Output

    Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

    Sample Input

    5
    Ab3bd

    Sample Output

    2

    Source

    大意:和GDUT那道完美串一样,不过这道5000*5000的数组会TLE所以要利用滚动数组降到2*5000,因为DP没有后效性,所以用0,1来存储每个状态

    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    const int MAX = 5100;
    int dp[2][MAX];
    char s1[MAX],s2[MAX];
    int main()
    {
        int n;
        scanf("%d%s",&n,s1);
        int i,j;
        for(i = 0,j = n - 1; i < n ; i++,j--)
        s2[i] = s1[j];
        int e = 0;
        memset(dp,0,sizeof(dp));
        for(int i = 0 ; i < n ;i++){
             e = 1 - e;
            for(int j = 0; j < n ;j++){
                if(s1[i] == s2[j])
                  dp[e][j+1] = dp[1-e][j]+1;
                else
                 dp[e][j+1] = max(dp[e][j],dp[1-e][j+1]);
            }
        }
        printf("%d",n-dp[e][n]);
       return 0;
    }
    View Code
  • 相关阅读:
    Spring Boot Logback应用日志
    Spring Boot Logback应用日志
    Spring boot Mybatis
    Spring boot Mybatis
    Spring boot Mybatis
    Spring Boot,Spring Data JPA多数据源支持
    无限循环输入
    生成四位随机不重复验证码
    ExcelUtil
    智能社- 牛逼的splice
  • 原文地址:https://www.cnblogs.com/zero-begin/p/4368783.html
Copyright © 2011-2022 走看看