zoukankan      html  css  js  c++  java
  • HDU1025——LIS——Constructing Roads In JGShining's Kingdom

    Problem Description
    JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

    Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource. 

    With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

    Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II. 

    The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones. 

    But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

    For example, the roads in Figure I are forbidden.



    In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^
     
    Input
    Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.
     
    Output
    For each test case, output the result in the form of sample. 
    You should tell JGShining what's the maximal number of road(s) can be built. 
     
    Sample Input
    2 1 2 2 1 3 1 2 2 3 3 1
     
    Sample Output
    Case 1: My king, at most 1 road can be built. Case 2: My king, at most 2 roads can be built.
    Hint
    Huge input, scanf is recommended.
     
    Author
    JGShining(极光炫影)

     大意:看出来是LIS,结果在输入方面以为是已经按照顺序了。。。小坑

    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    const int maxn = 501010;
    int a[maxn],b[maxn];
    int main()
    {
        int n,cas = 1;
        int p,q;
           while(~ scanf("%d",&n)){
            memset(a,0,sizeof(a));
            memset(b,0,sizeof(b));
        for(int i = 1; i <= n ;i++){
            scanf("%d%d",&p,&q);
            a[p] = q;
        }
        b[1] = a[1];
        int k,i;
        int l,r,mid;
        for(i = 2, k = 1; i <= n;i++){
            if(a[i] > b[k]) b[++k] = a[i];
            else {
                l = 1;r = k;
                while(l <= r){
                    mid = (l+r) >> 1;
                    if(b[mid] < a[i]) l = mid + 1;
                    else if(b[mid] > a[i]) r = mid - 1;
                    else break;
                }
                b[l] = a[i];
            }
        }
        if(k == 1)
        printf("Case %d:
    My king, at most %d road can be built.
    
    ",cas,k);
        else printf("Case %d:
    My king, at most %d roads can be built.
    
    ",cas,k);
        cas++; 
        }
    return 0;
    }
    

      

  • 相关阅读:
    powershell和cmd区别
    装饰器笔记
    url参数和字典的相互转化
    Python装饰器详解
    python字符串格式化f-string
    Python函数(function)与方法(method)区别
    jenkins钉钉插件报错keywords not in content
    jenkins配置邮件
    vim常用操作
    Vue之axios请求
  • 原文地址:https://www.cnblogs.com/zero-begin/p/4523246.html
Copyright © 2011-2022 走看看