zoukankan      html  css  js  c++  java
  • POJ 2255 Tree Recovery

    标题来源:http://poj.org/problem?id=2255


    Tree Recovery
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 11649   Accepted: 7311

    Description

    Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 
    This is an example of one of her creations: 
                                                   D
    
                                                  / 
    
                                                 /   
    
                                                B     E
    
                                               /      
    
                                              /        
    
                                             A     C     G
    
                                                        /
    
                                                       /
    
                                                      F
    
    

    To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 
    She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

    Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 
    However, doing the reconstruction by hand, soon turned out to be tedious. 
    So now she asks you to write a program that does the job for her! 

    Input

    The input will contain one or more test cases. 
    Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 
    Input is terminated by end of file. 

    Output

    For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

    Sample Input

    DBACEGF ABCDEFG
    BCAD CBAD
    

    Sample Output

    ACBFGED
    CDAB
    

    Source


    题意:

    给出二叉树的前序和中序遍历,求后序遍历


    题解:

    依据三种遍历的特点

    1.前序遍历: 根 左 右

    2.中序遍历:左  根 右 

    3.后序遍历:左 右  右

    首先依据前序遍历确定根节点,然后再依据中序遍历确定左子树和右子树,然后再按此方法依次递归左子树和右子树并将根节点入栈。

    最后,栈中保存的便是该树的后序遍历。


    PS: 这题在半年前就看过,那个时候对树的遍历并不熟悉~~ 还不全然理解,也就不会打代码了~  今天中午又把这题翻出来。略微分析一下非常快就实现了。一次AC


    AC代码:

    #include<iostream>
    #include<string>
    using namespace std;
    int posmap[256];
    string pretree,midtree,posttree="";
    void init()
    {
    	posttree="";
    	for(int i=0;i<pretree.size();i++)
    	posmap[pretree[i]]=i+1;
    }
    void postorder(int left,int right)
    {
    	if(left==right) return ;
    	int Min=posmap[midtree[left]],Mpos=left;
    	for(int i=left+1;i<right;i++){
    		if(Min>posmap[midtree[i]]){
    			Min=posmap[midtree[i]];
    			Mpos=i;
    		}
    	}
    	postorder(left,Mpos);
    	postorder(Mpos+1,right);
    	posttree+=midtree[Mpos];
    }
    int main()
    {
    	while(cin>>pretree>>midtree)
    	{
    		init();
    		postorder(0,midtree.size());
    		cout<<posttree<<endl;
    	}
    	return 0;
    }





  • 相关阅读:
    关于WEB页面的强制分页打印问题
    iOS地图多个自定义大头针绘制核心代码
    PHP生成随机码
    安卓动画小结
    WKWebView遇到的问题汇总
    实现图片预加载的几种方式
    苹果所有常用证书,appID,Provisioning Profiles配置说明及制作图文教程
    markdown语法博客园测试
    Agreement has been updated--Edit Phone Number最便捷解决办法(不需要安全提示问题和双重认证)
    Python黑帽子:自动化内存取证
  • 原文地址:https://www.cnblogs.com/zfyouxi/p/4589389.html
Copyright © 2011-2022 走看看