zoukankan      html  css  js  c++  java
  • sicily 1007 To and Fro (基地称号)

    链接:http://soj.me/show_problem.php?pid=1007

    Description
    Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is "There's no place like home on a snowy night" and there are five columns, Mo would write down t o i o y h p k n n e l e a i r a h s g e c o n h s e m o t n l e w x Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character `x' to pad the message out to make a rectangle, although he could have used any letter. Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as toioynnkpheleaigshareconhtomesnlewx Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.
    Input
    There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2 . ..20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.
    Output
    Each input set should generate one line of output, giving the original plaintext message, with no spaces.
    Sample Input
     Copy sample input to clipboard
    5
    toioynnkpheleaigshareconhtomesnlewx
    3
    ttyohhieneesiaabss
    0
    
    Sample Output
    theresnoplacelikehomeonasnowynightx
    thisistheeasyoneab

    解题思路:

    依照加密的方式还原回去就能够了;


    代码例如以下:

    // Problem#: 1007
    // Submission#: 2815109
    // The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
    // URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
    // All Copyright reserved by Informatic Lab of Sun Yat-sen University
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <cstdlib>
    #define MAXN 205
    #define RST(N)memset(N, 0, sizeof(N))
    using namespace std;
    
    int columns;
    char str[MAXN];
    int len, cnt, temp, step;
    
    void Init()
    {
    	scanf("%s", str);
    	len = strlen(str);
    	cnt = 0;
    }
    
    int main()
    {
        while(~scanf("%d", &columns) && columns) {
    	Init();
            for (int i=0, j=0; cnt<len; i++) {
                temp = 2*columns*i + j;
                if(temp < len) {
                    putchar(str[temp]);
                    cnt++;
                }else {
                    i = -1;
                    j++;
                    continue;
                }
                temp = 2*columns*(i+1) - 1 - j;
                if (cnt < len && temp < len) {
                    putchar(str[temp]);
                    cnt++;
                }else {
                    i = -1;
                    j++;
                }
            }
            puts("");
        }
        return 0;
    }                                 


    版权声明:本文博客原创文章。博客,未经同意,不得转载。

  • 相关阅读:
    java、asp.net 通用分页码函数
    SQL
    go build 参数
    alertmanager报错Failed to get final advertise address: No private IP address found, and explicit IP not provided"
    go语言三个点的用法
    CDH6.2安装
    python之链表
    jenkins触发构建后一直重复构建
    ansible远程执行寻找不到环境变量问题
    Python3之harbor sdk api
  • 原文地址:https://www.cnblogs.com/zfyouxi/p/4744126.html
Copyright © 2011-2022 走看看