zoukankan      html  css  js  c++  java
  • HDU 2828 DLX搜索

    Lamp

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 771    Accepted Submission(s): 230
    Special Judge


    Problem Description
    There are several switches and lamps in the room, however, the connections between them are very complicated. One lamp may be controlled by several switches, and one switch may controls at most two lamps. And what’s more, some connections are reversed by mistake, so it’s possible that some lamp is lighted when its corresponding switch is “OFF”!

    To make things easier, we number all the lamps from 1 to N, and all the switches 1 to M. For each lamps, we give a list of switches controlling it. For example, for Lamp 1, the list is “1 ON 3 OFF 9 ON”, that means Lamp 1 will be lighted if the Switch 1 is at the “ON” state OR the Switch 3 is “OFF” OR the Switch 9 is “ON”.

    Now you are requested to turn on or off the switches to make all the lamps lighted.
     

    Input
    There are several test cases in the input. The first line of each test case contains N and M (1 <= N,M <= 500), then N lines follow, each indicating one lamp. Each line begins with a number K, indicating the number of switches controlling this lamp, then K pairs of “x ON” or “x OFF” follow.
     

    Output
    Output one line for each test case, each contains M strings “ON” or “OFF”, indicating the corresponding state of the switches. For the solution may be not unique, any correct answer will be OK. If there are no solutions, output “-1” instead.
     

    Sample Input
    2 2 2 1 ON 2 ON 1 1 OFF 2 1 1 1 ON 1 1 OFF
     

    Sample Output
    OFF ON -1


    DLX简单搜索。纠结了好久,行为2*m,每个开关ON,OFF两种状态,列为n,代表灯的状态,然后依照反复覆盖搜索。不须要估价函数,用一个vis数组记录开关状态即可。

    代码:

    /* ***********************************************
    Author :rabbit
    Created Time :2014/4/9 17:58:16
    File Name :7.cpp
    ************************************************ */
    #pragma comment(linker, "/STACK:102400000,102400000")
    #include <stdio.h>
    #include <iostream>
    #include <algorithm>
    #include <sstream>
    #include <stdlib.h>
    #include <string.h>
    #include <limits.h>
    #include <string>
    #include <time.h>
    #include <math.h>
    #include <queue>
    #include <stack>
    #include <set>
    #include <map>
    using namespace std;
    #define INF 0x3f3f3f3f
    #define eps 1e-8
    #define pi acos(-1.0)
    typedef long long ll;
    struct DLX{
        const static int maxn=200010;
        #define FF(i,A,s) for(int i = A[s];i != s;i = A[i])
        int L[maxn],R[maxn],U[maxn],D[maxn];
        int size,col[maxn],row[maxn],s[maxn],H[maxn];
        bool vis[1200];
        int ans[maxn],cnt;
        void init(int m){
            for(int i=0;i<=m;i++){
                L[i]=i-1;R[i]=i+1;U[i]=D[i]=i;s[i]=0;
            }
            memset(H,-1,sizeof(H));
            L[0]=m;R[m]=0;size=m+1;
            memset(vis,0,sizeof(vis));
        }
        void link(int r,int c){
             U[size]=c;D[size]=D[c];U[D[c]]=size;D[c]=size;
             if(H[r]<0)H[r]=L[size]=R[size]=size;
             else {
                 L[size]=H[r];R[size]=R[H[r]];
                 L[R[H[r]]]=size;R[H[r]]=size;
             }
             s[c]++;col[size]=c;row[size]=r;size++;
         }
        void del(int c){//精确覆盖
            L[R[c]]=L[c];R[L[c]]=R[c];  
            FF(i,D,c)FF(j,R,i)U[D[j]]=U[j],D[U[j]]=D[j],--s[col[j]];  
        }  
        void add(int c){  //精确覆盖
            R[L[c]]=L[R[c]]=c;  
            FF(i,U,c)FF(j,L,i)++s[col[U[D[j]]=D[U[j]]=j]];  
        }  
        bool dfs(int k){//精确覆盖
            if(!R[0]){  
                cnt=k;return 1;  
            }  
            int c=R[0];FF(i,R,0)if(s[c]>s[i])c=i;  
            del(c);  
            FF(i,D,c){  
                FF(j,R,i)del(col[j]);  
                ans[k]=row[i];if(dfs(k+1))return true;  
                FF(j,L,i)add(col[j]);  
            }  
            add(c);  
            return 0;
        }  
        void remove(int c){//反复覆盖
            FF(i,D,c)L[R[i]]=L[i],R[L[i]]=R[i];
        }
         void resume(int c){//反复覆盖
             FF(i,U,c)L[R[i]]=R[L[i]]=i;
         }
        int A(){//估价函数
            int res=0;
            memset(vis,0,sizeof(vis));
            FF(i,R,0)if(!vis[i]){
                    res++;vis[i]=1;
                    FF(j,D,i)FF(k,R,j)vis[col[k]]=1;
                }
            return res;
        }
        bool dance(int now){//反复覆盖
            if(R[0]==0)return 1;
                int temp=INF,c;
                FF(i,R,0)if(temp>s[i])temp=s[i],c=i;
                FF(i,D,c){
                    if(vis[row[i]^1])continue;
                    vis[row[i]]=1;remove(i);
                    FF(j,R,i)remove(j);
                    if(dance(now+1))return 1;
                    FF(j,L,i)resume(j);
                    resume(i);vis[row[i]]=0;
                }
                return 0;
        }
    }dlx;
    int main(){
        int n,m;
        while(~scanf("%d%d",&n,&m)){
            dlx.init(n);
            for(int i=1;i<=n;i++){
                int a,b;char str[44];
                scanf("%d",&a);
                while(a--){
                    scanf("%d%s",&b,str);
                    if(str[1]=='N')dlx.link((b-1)<<1,i);
                    else dlx.link((b-1)<<1|1,i);
                }
            }
            if(!dlx.dance(0))puts("-1");
            else{
                if(!dlx.vis[1])printf("ON");else printf("OFF");
                for(int i=2;i<(m<<1);i+=2){
                    if(!dlx.vis[i])printf(" OFF");else printf(" ON");
                }
    			puts("");
            }
        }
        return 0;
    }
    
    
    


  • 相关阅读:
    《新土改:土地制度改革焦点难点辨析》:土地涨价要归公并用于城市配套设施,城市化的主角是人,小产权房不应该合法化,四星
    《清明上河图密码》:北宋的福尔摩斯探案,五星
    《中国的人口与城市》:关于中国人口与中国城市的数据分析,4星推荐。
    《集体失忆的黑暗时代》:已故加拿大公共知识分子关于城市规划与人类文明的随笔,三星推荐
    《智慧社会:大数据与社会物理学》:研究人类的想法的流动扩散的规律,四星
    《中国东部三大都市圈城市体系演化机制研究》:博士论文,结论是北上广深城市化规模还是不够,三星推荐
    《中国十亿城民——人类历史上最大规模人口流动背后的故事》:中国城市化将继续,城市对外来务工者应该更友好更包容,三星
    [Javascript] JavaScript赋值时的传值与传址
    [Vue @Component] Pass Props Between Components with Vue Slot Scope & renderless component
    [Dart] Understand Variables and Constants in Dart
  • 原文地址:https://www.cnblogs.com/zfyouxi/p/5040926.html
Copyright © 2011-2022 走看看